はじめての自宅サーバ構築 - Fedora/CentOS -
Last Update 2018/01/16
[ 更新履歴 ] [ サイト マップ ] [ 質問掲示板 ] [ 雑談掲示板 ] [ リンク ]
トップ >> 質問掲示板

 このスレッドはクローズされています。記事の閲覧のみとなります。

 メールサーバに接続出来ません
日時: 2013/05/06 20:40
名前: ぱみゅ

1.不明点・障害内容:メールサーバにつながらない?
2.ログの有無   :メールソフトのログ
■アカウント: mail@myhost.net でのエラー。
POP3用のユーザーアカウントが拒否されました。
エラー内容 = Plaintext authentication disallowed on non-secure (SSL/TLS) connections.
  (有:その内容) :
3.Distribution  :CentOS
      Version :6.2
4.Service Name  :postfix
      Version :
5.ネットワーク構成:
 メールサーバとしてpostfixとdovecotをこのサイトの解説を読みながら設定しました。メールソフト側では
IDとパスワードを設定し、送信受信サーバにはサーバのグローバルIPアドレスを入れてあります。
この状態で受信しようとすると上記のようにエラーになります。送信しようとすると
サーバのIPアドレスに接続はするのですが、「長時間応答がありません」となって送信もできません。
何か設定が足りないのでしょうか?
メンテ

Page:  [1] [2] [3] [4] [5] [6] [7] [8] [9] [10] [11] [12]

■ コンテンツ関連情報

 Re: メールサーバに接続出来ません ( No.6 )
日時: 2013/05/07 22:09
名前: ぱみゅ

くりきんとんさん、ありがとうございます。

>    コメント解除にしてnoでやってみたら? 

 noにしてやってみましたが、メーラからみた状況は変わりませんでしたが、ログの状況は変わりました。

May 7 20:41:21 v157-***-***-*** dovecot: pop3-login: Disconnected (Auth failed,1 attempts): use=<mail@myhost.net>, method=PLAIN ,rip=***.***.***.***,lip=***.***.***.***

 毎度のことながら知識不足で済みません。ただ、dovecot.confは現在正常に稼働しているサーバから抜き出したものを新しいサーバ機に移していますので、これの設定は間違っていないと思います。ただOSがCentOS5.8から6.2に変わったことでなに感の設定が足りなくなってるのかと考えています。

メンテ
 Re: メールサーバに接続出来ません ( No.7 )
日時: 2013/05/08 14:19
名前: stranger
参照: http://ja.528p.com/

認証に失敗しているようですね

CentOS 5.x は dovecot 1.x
CentOS 6.x は dovecot 2.x
なので設定ファイルの構成や設定値の違いがあります

dovecot 1.xのdovecot.confをdovecot1.confなどにコピーして
下記コマンドを実行し、dovecot 2.xに対応した設定値に替えて出力し
分割された設定ファイルのなかで指定します
(errorがでたらその部分を無効にして再度doveconfを実行)
変更内容を分割された設定ファイルのなかで捜すのが大変だけど頑張る

doveconf -n -c dovecot1.conf > dovecot2.conf

あくまで参考 コンソールに警告がでて、dovecot2.confに変更が必要な設定例が記録される

設定例
dovecot.confの最終行近くの
!include conf.d/*.conf
の設定により
/etc/dovecot/conf.dのすべてのconfファイルが読み込まれ
10-auth.confの最終行近くの
!include auth-system.conf.ext
の設定により
auth-system.conf.extが読み込まれます
auth-system.conf.extで

passdb {
  driver = pam
}

userdb {
  driver = passwd
}

が設定されています
メンテ
 Re: メールサーバに接続出来ません ( No.8 )
日時: 2013/05/08 16:28
名前: ぱみゅ

strangerさん、いつもありがとうございます。
 ご助言とこのサイトの説明に従って下記のように設定しました。(頑張ってみました)

<dovecot.conf>
protocols = imap pop3

<conf.d/10-mail.conf>
mail_location = maildir:~Maildir
valid_chroot¥dirs = /home

<conf.d/20-pop3.conf>
popr_uidl_format = %u

<conf.d/10-auth.conf>
disable_plaintext_auth = no
auth_mechanism = plain login

<auth-system.conf.ext>
passdb {
  driver = pam
}
userdb {
  driver = passwd
}

これらの変更と確認を行なってdovecotを再起動し、受信しにいった時のログです。
May 8 15:50:33 v***-***-***-*** dopvecot: master: Dovecot v2.0.9 startingup(core dumps disabled)
May 8 15:50:44 v***-***-***-*** pop3-login: Disconnected (auth failed,1 attempts): user=<mai@myhost.net>, method=PLAIN, rip=***.***.***.***, lip=***.***.***.***
まだ何か足りないか間違っているでしょうか? それともメーラのログに

アカウント: mail@myhost.net でのエラー。
POP3用のパスワードが間違っているか、または認証に失敗しました。
エラー内容 = Authentication failed.

とでることかたAuthの設定がマズイのでしょうか?
メンテ
 Re: メールサーバに接続出来ません ( No.9 )
日時: 2013/05/08 16:44
名前: stranger
参照: http://ja.528p.com/

user=<mai@myhost.net>
mailは特権ユーザですよね

/etc/passwdに記述されている実際のユーザのUIDを調べてください
UID 500 以上の一般ユーザの必要があります
そして念のためもう一度パスワードの設定をしてみてください

すくなくともサーバには到達しているので、どこか勘違いしているのかも
メンテ
 Re: メールサーバに接続出来ません ( No.10 )
日時: 2013/05/08 18:29
名前: ゆりこ姫

私のメールサーバーの設定が一般的なのかどうか知りませんが、
ログには user=<hoge> のようにドメイン名が入らないで記録されます。

メールクライアントの設定の中で、
SMTP認証に使うユーザー名(アカウント名?)のところで
hogeとするところが、hoge@myhost.net になってるのでは?

hoge@myhost.net みたいになっていたら、hoge だけにしてアクセスしてみるといいかも。
メンテ

Page:  [1] [2] [3] [4] [5] [6] [7] [8] [9] [10] [11] [12]

■ その他

ページ先頭へ

Copyright(©)2004-2018 First home server construction. All Right Reserved.