はじめての自宅サーバ構築 - Fedora/CentOS -
Last Update 2018/01/16
[ 更新履歴 ] [ サイト マップ ] [ 質問掲示板 ] [ 雑談掲示板 ] [ リンク ]
トップ >> 当サイト情報 >> スレッド

このページは表示専用です。新規投稿・レスや最新情報はこちらです。

このスレッドはクローズされています。記事の閲覧のみとなります。

 yum-y updateのエラー
日時: 2013/03/15 17:07
名前: ふくろう

1.不明点・障害内容:
2.ログの有無   :
  (有:その内容) :
3.Distribution  :CentOS6.3
      Version :
4.Service Name  :
      Version :
5.ネットワーク構成:

こんにちは。

久しぶりでyum-y updateしたら最後で下記のエラーがでてしまい困ってしまいました。
どなたか解決策をお教えいただきたいのですが。
epelは入れてありインストールしてあります。

尚、clamdを一旦削除して再度インストールしたのですがupdateでまた Not foundになってしまいました。

当方は初心者です、どうぞよろしくお願いhします。

---> Package perl-XML-NamespaceSupport.noarch 0:1.10-3.el6 will be installed
--> Processing Dependency: /etc/clamd.d for package: amavisd-new-2.8.0-4.el6.noarch
--> Finished Dependency Resolution
Error: Package: amavisd-new-2.8.0-4.el6.noarch (epel)
Requires: /etc/clamd.d
Available: clamd-0.97.6-1.el6.i686 (epel)
Not found
Available: clamd-0.96.4-1.el6.rf.i686 (dag)
Not found
Available: clamd-0.96.5-1.el6.rf.i686 (dag)
Not found
Available: clamd-0.97-1.el6.rf.i686 (dag)
Not found
Available: clamd-0.97.1-1.el6.rf.i686 (dag)
Not found
Available: clamd-0.97.2-1.el6.rf.i686 (dag)
Not found
Available: clamd-0.97.3-1.el6.rf.i686 (dag)
Not found
Available: clamd-0.97.4-1.el6.rf.i686 (dag)
Not found
Available: clamd-0.97.5-1.el6.rf.i686 (dag)
Not found
Available: clamd-0.97.5-2.el6.rf.i686 (dag)
Not found
Installing: clamd-0.97.6-1.el6.rf.i686 (dag)
Not found
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest


■ コンテンツ関連情報

 Re: yum-y updateのエラー ( No.1 )
日時: 2013/03/15 18:11
名前: stranger
参照: http://ja.528p.com/

clamd-0.97.6-1.el6.i686には
/etc/clamd.dが含まれています

yumをcleanしてupdateをかけてみたら

検索結果
$ yum provides */clamd.d --enablerepo=epel

clamd-0.97.6-1.el6.i686 : The Clam AntiVirus Daemon
Repo : epel
Matched from:
Filename : /etc/clamd.d
 Re: yum-y updateのエラー ( No.2 )
日時: 2013/03/15 18:23
名前: 腰巾着

Error: Package: amavisd-new-2.8.0-4.el6.noarch (epel)

見てみるとepelの
x86_64はamavisd-new-2.6.4-2.el6に対し
i386はamavisd-new-2.8.0-4.el6

となってますね。

なんでかな?


amavisd-newが今インストールされているなら削除してepel-releaseも削除するか

/etc/yum.repos.d/epel.repoのenabled=1をenabled=0にしておいて

amavisd-newをdagからインストールすれば良いでしょう。

epelとdagと混在させると面倒な事になるので、どっちかに絞った方が良いかと。
 Re: yum-y updateのエラー ( No.3 )

** 返信者によって削除されました

 Re: yum-y updateのエラー ( No.4 )
日時: 2013/03/15 20:07
名前: ふくろう

腰巾着 さん、ありがとうございます。
yum clean allで全てのキャッシュを削除しましたがだめでした。

ちょっと頭が混乱しています。

>amavisd-newが今インストールされているなら削除して
amavisd-newを一旦削除して
dagから再インストールしてyum-y updateをするとエラーは無しです。
packageのアップデートは出てきません。


また/etc/yum.repos.d/epel.repoのenabled=1ですとやはりエラーです。

初心者の自分には何がなんだか。

[root@abcdefg ~]# yum update
Loaded plugins: fastestmirror, refresh-packagekit
Loading mirror speeds from cached hostfile
* base: ftp.iij.ad.jp
* epel: ftp.tsukuba.wide.ad.jp
* extras: ftp.iij.ad.jp
* updates: ftp.iij.ad.jp
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package amavisd-new.i686 0:2.6.6-3.el6.rf will be updated
---> Package amavisd-new.noarch 0:2.8.0-4.el6 will be an update
--> Processing Dependency: unzoo for package: amavisd-new-2.8.0-4.el6.noarch
--> Processing Dependency: perl(Razor2::Client::Version) for package: amavisd-ne w-2.8.0-4.el6.noarch
--> Processing Dependency: perl(Net::LDAP) for package: amavisd-new-2.8.0-4.el6. noarch
--> Processing Dependency: perl(Mail::SPF) for package: amavisd-new-2.8.0-4.el6. noarch
--> Processing Dependency: perl(Authen::SASL) for package: amavisd-new-2.8.0-4.e l6.noarch
--> Processing Dependency: p7zip-plugins for package: amavisd-new-2.8.0-4.el6.no arch
--> Processing Dependency: lrzip for package: amavisd-new-2.8.0-4.el6.noarch
--> Processing Dependency: /usr/sbin/clamd for package: amavisd-new-2.8.0-4.el6. noarch
--> Processing Dependency: /etc/clamd.d for package: amavisd-new-2.8.0-4.el6.noa rch
--> Running transaction check
---> Package clamd.i686 0:0.97.6-1.el6 will be installed
--> Processing Dependency: clamav = 0.97.6-1.el6 for package: clamd-0.97.6-1.el6 .i686
---> Package lrzip.i686 0:0.614-1.el6 will be installed
---> Package p7zip-plugins.i686 0:9.20.1-2.el6 will be installed
---> Package perl-Authen-SASL.noarch 0:2.13-2.el6 will be installed
--> Processing Dependency: perl(GSSAPI) for package: perl-Authen-SASL-2.13-2.el6 .noarch
---> Package perl-LDAP.noarch 1:0.40-1.el6 will be installed
--> Processing Dependency: perl(XML::SAX::Writer) for package: 1:perl-LDAP-0.40- 1.el6.noarch
--> Processing Dependency: perl(XML::SAX::Base) for package: 1:perl-LDAP-0.40-1. el6.noarch
--> Processing Dependency: perl(Convert::ASN1) for package: 1:perl-LDAP-0.40-1.e l6.noarch
---> Package perl-Mail-SPF.noarch 0:2.007-1.el6 will be installed
---> Package perl-Razor-Agent.i686 0:2.85-6.el6 will be installed
---> Package unzoo.i686 0:4.4-7.el6 will be installed
--> Running transaction check
---> Package clamd.i686 0:0.97.6-1.el6 will be installed
--> Processing Dependency: clamav = 0.97.6-1.el6 for package: clamd-0.97.6-1.el6 .i686
---> Package perl-Convert-ASN1.noarch 0:0.22-1.el6 will be installed
---> Package perl-GSSAPI.i686 0:0.26-6.el6 will be installed
---> Package perl-XML-SAX.noarch 0:0.96-7.el6 will be installed
--> Processing Dependency: perl(XML::NamespaceSupport) for package: perl-XML-SAX -0.96-7.el6.noarch
--> Processing Dependency: perl(XML::LibXML::Common) for package: perl-XML-SAX-0 .96-7.el6.noarch
--> Processing Dependency: perl(XML::LibXML) for package: perl-XML-SAX-0.96-7.el 6.noarch
---> Package perl-XML-SAX-Writer.noarch 0:0.50-8.el6 will be installed
--> Processing Dependency: perl(XML::Filter::BufferText) for package: perl-XML-S AX-Writer-0.50-8.el6.noarch
--> Processing Dependency: perl(Text::Iconv) for package: perl-XML-SAX-Writer-0. 50-8.el6.noarch
--> Running transaction check
---> Package clamd.i686 0:0.97.6-1.el6 will be installed
--> Processing Dependency: clamav = 0.97.6-1.el6 for package: clamd-0.97.6-1.el6 .i686
---> Package perl-Text-Iconv.i686 0:1.7-6.el6 will be installed
---> Package perl-XML-Filter-BufferText.noarch 0:1.01-8.el6 will be installed
---> Package perl-XML-LibXML.i686 1:1.70-5.el6 will be installed
---> Package perl-XML-NamespaceSupport.noarch 0:1.10-3.el6 will be installed
--> Finished Dependency Resolution
Error: Package: clamd-0.97.6-1.el6.i686 (epel)
Requires: clamav = 0.97.6-1.el6
Installed: clamav-0.97.6-1.el6.rf.i686 (@dag)
clamav = 0.97.6-1.el6.rf
Available: clamav-0.97.6-1.el6.i686 (epel)
clamav = 0.97.6-1.el6
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
尚、他のパッケージは「yum --skip-broken update」でアップデートしています。
 Re: yum-y updateのエラー ( No.5 )
日時: 2013/03/15 20:53
名前: くりくり

CentOSにはオリジナルリポジトリ以外にサードパーティのリポジトリというのがあります。
車でいうと純正の部品じゃねーけと、使えますよというのがepelとdag

enabled=0だとyum -y update --enablerepo=dag
enabled=1だとyum -y update

enabled=1だとdagのパッケージとCentOSオリジナルが上書きしたりトラブルのもとになるんで
オリジナルを優先、dagを普通みたい設定をする。
腰巾着 さんが仰ってるのは
dagとepelがかぶってるのでdagにしましょうということ
 Re: yum-y updateのエラー ( No.6 )
日時: 2013/03/15 23:44
名前: 腰巾着

夕方は以下しか無かったに
ftp://ftp.riken.jp/Linux/fedora/epel/6/x86_64/amavisd-new-2.6.4-2.el6.noarch.rpm

さっき見たら入ってました。
ftp://ftp.riken.jp/Linux/fedora/epel/6/x86_64/amavisd-new-2.8.0-4.el6.noarch.rpm



clamd・clamav・amavisd-newが入っていない状態での話しです。

epelとdagを同居させた状態で

yum -y install amavisd-newを行うと

Error: Package: amavisd-new-2.8.0-4.el6.noarch (epel)

ここで引っかかります。

epel.repoのenabled=1をenabled=0にするとdagからインストール出来ます。

同様にrpmforge.repoのenabled = 1をenabled = 0するとepelからインストールできます。




結局どちらを使うかですね。

新しい物好きならepel、そうでなければdag?

dagに比べepelの方が色々揃っています。

私的にはepelを基本として、epelに無い物はdagから入れる方が良いように感じますが。

まぁ、お好みで。


2.6.6-2.el6
amavisd-new - Mail virus-scanner


AMaViS is a program that interfaces a mail transfer agent (MTA) with one or more virus scanners.

Amavisd-new is a branch created by Mark Martinec that adds serveral performance and robustness features.

It's partly based on work being done on the official amavisd branch.

Please see the README.amavisd-new-RELNOTES file for a detailed description.



2.8.0-4.el6
amavisd-new - Email filter with virus scanner and spamassassin support


amavisd-new is a high-performance and reliable interface between mailer (MTA)

and one or more content checkers: virus scanners, and/or Mail::SpamAssassin Perl module.

It is written in Perl, assuring high reliability, portability and maintainability.

It talks to MTA via (E)SMTP or LMTP, or by using helper programs.

No timing gaps exist in the design which could cause a mail loss.
 Re: yum-y updateのエラー ( No.7 )
日時: 2013/03/16 14:49
名前: ふくろう

皆様、いろいろありがとうございました。

amavisd-newを一旦削除してetc/yum.repos.d/epel.repoのenabled=1をenabled=0に

その後、amavisd-newをdagからインストールしました。

>epelとdagと混在させると面倒な事になるので、どっちかに絞った方が良いかと。
これからはenabled=0にしてdagにしぼってインストール&アップデートをします。

いまだに何故yum updateでエラーになってしまったのかがよく分かりませんが
結局のところ、
RPMデータベースに複数のバージョンのパッケージが存在しててそれがアップデートが出来なかった原因でしょうか?

初心者で、あちこち手を出すと分からなくなってしまうのでdagに絞ってやっていきたいと思います。



 Re: yum-y updateのエラー ( No.8 )
日時: 2013/03/16 14:54
名前: 腰巾着

>いまだに何故yum updateでエラーになってしまったのかがよく分かりませんが

Error: Package: amavisd-new-2.8.0-4.el6.noarch (epel)

これが原因ですが。


今の所dagにはamavisd-new-2.8がありません。

現時点ではamavisd-new-2.6ですが、

どちらのリポジトリも有効な状態だったので

アップデート時にepelのamavisd-new-2.8を見に行ってしまい

結果、依存関係のエラーが出ただけです。




>下記のようにLogwatchに「OUTDATED!」と、うるさく出るのでClamAV0.97.7を入れたい

dagもepelも0.97.6ですね。

待っていればその内アップデートしますが

気になるならソースから入れたら良いと思います。

後のアップデートが苦にならないのであれば。


ClamAVのrpmファイルはdagよりepelの方が更新が早かったと思います。


まぁ、お好きなように。


Good Luck!
 Re: yum-y updateのエラー ( No.9 )
日時: 2013/03/16 17:45
名前: ふくろう

腰巾着 さん、こんにちは。

いろいろ細かく分かりやすいご教示に感謝いたします。

ほんとうにありがとうございました。

分からなかった原因が判明して混乱してた頭の中がすっきりいたしました、

「目から鱗が落ちる」ような思いです。

ClamAV0.97.7の件もありがとうございました。


他の皆様もお世話になりました。
 Re: yum-y updateのエラー ( No.10 )
日時: 2013/03/19 11:44
名前: ゆりこ姫

結局どう対処したのか気になりますわ・・・

ところで、分かってるとは思うのですが、3rd partyのrepositoryでenabled=1にしたまま
# yum -y update
とかやると、確認なしで全パッケージをアップデートしようとします。
結果、意図せずしていろいろなパッケージまでもアップデートされちゃいますからご注意を。
(3rd partyと同じになっていいなら構わないけどね)

だから普通(かどうか知らないけど)は、3rd partyではenabled=0にしておいて
必要性のあるときにだけ、--enablerepo=xxx で有効にしてyumを実行するんだと思います。
 Re: yum-y updateのエラー ( No.11 )
日時: 2013/03/19 13:13
名前: stranger
参照: http://ja.528p.com/

--enablerepo=xxxで有効にしてupdateかければ
その時点でenable=1を設定したことと同じだと思う

yum-plugin-prioritiesをいれて
priority=1
priority=2
priority=3
で優先度をつける
同じバージョンのパッケージがあった場合
priorityで優先される方(1が最優先)が使われると思う

詳細はnet検索してください
 Re: yum-y updateのエラー ( No.12 )
日時: 2013/03/19 16:04
名前: ゆりこ姫

yum-plugin-prioritiesの場合には、

http://docs.fedoraproject.org/en-US/Fedora/14/html/Software_Management_Guide/ch06s14.html
>yum-plugin-priorities
>This extension allows repositories to have different priorities. Packages in a low priority repository can not replace packages installed from repositories with higher priority, even if it has an updated version.

"even if it has an updated version"とあるところがご注意かも。

例えば、baseを最優先(priority=1)にして、epelをそれより低い(priority=10)とかしたときに、
epelにいくら最新版のパッケージがあっても、baseに同じパッケージで古いものがあると
最新にはupdateされません。
要するにversionよりpriorityが優先されます。
 Re: yum-y updateのエラー ( No.13 )
日時: 2013/03/19 17:31
名前: stranger
参照: http://ja.528p.com/

一時的にenableにした場合でも
enableならばそのrepoをよみにいきます
当然 デフォルトでenableになっているrepoも読みにいきます
epelだけを有効にしたいなら

yum update --disablerepo=* --enablerepo=epel

のように使います

サードパーティに優先順位をつける

単独に存在するパッケージは、priorityに影響されないから
epelやrpmforgeだけに存在するパッケージは最新版があれば
アップデートされると思う

どうしてもダブる場合は
必要のないほうにexclude設定を追加する

priorityがわかりにくかったら
exclude設定だけでも良いかも?

■ その他

ページ先頭へ


Copyright(©)2004-2018 First home server construction. All Right Reserved.