はじめての自宅サーバ構築 - Fedora/CentOS -
Last Update 2018/01/16
[ 更新履歴 ] [ サイト マップ ] [ 質問掲示板 ] [ 雑談掲示板 ] [ リンク ]
トップ >> 当サイト情報 >> スレッド

このページは表示専用です。新規投稿・レスや最新情報はこちらです。

このスレッドはクローズされています。記事の閲覧のみとなります。

 centos4でのyumのインストール
日時: 2007/08/21 15:11
名前: 田中

centos4を使用している初心者です。

レンタルしている(使用しているサーバ)サーバに
yumがインストールされていなかったのでインストールしようと思い

http://kajuhome.com/yum.shtml#n02

のやり方にそってやってみました。

wget http://ftp.riken.jp/Linux/centos/4/os/i386/CentOS/RPMS/yum-2.4.3-1.c4.noarch.rpm

が既に無かったので

wget http://ftp.riken.jp/Linux/centos/4/os/i386/CentOS/RPMS/yum-2.4.3-3.el4.centos.noarch.rpm

でおこないました。
収得したRPMのパッケージをインストールしようと

rpm -ivh yum-2.4.3-3.el4.centos.noarch.rpm

としたら

error: Failed dependencies:
    python-elementtree is needed by yum-2.4.3-3.el4.centos.noarch
    python-sqlite is needed by yum-2.4.3-3.el4.centos.noarch
    urlgrabber is needed by yum-2.4.3-3.el4.centos.noarch

とのエラーが表示されました。おそらく上記エラーの3つのファイルが必要だと思うのですが
どうやって用意すればよいかわかりません。どなたかご教授頂けないでしょうか?

■ コンテンツ関連情報

 Re: centos4でのyumのインストール ( No.1 )
日時: 2007/08/21 17:19
名前: 管理者

> 収得したRPMのパッケージをインストールしようと
>
> rpm -ivh yum-2.4.3-3.el4.centos.noarch.rpm
>
> としたら
>
> error: Failed dependencies:
>     python-elementtree is needed by yum-2.4.3-3.el4.centos.noarch
>     python-sqlite is needed by yum-2.4.3-3.el4.centos.noarch
>     urlgrabber is needed by yum-2.4.3-3.el4.centos.noarch
>
> とのエラーが表示されました。


上記バージョンの「yum」であれば下記を行ってみてください。

# wget http://ftp.riken.jp/Linux/centos/4/os/i386/CentOS/RPMS/yum-2.4.3-1.c4.noarch.rpm
# wget http://ftp.riken.jp/Linux/centos/4/os/i386/CentOS/RPMS/python-elementtree-1.2.6-5.el4.centos.i386.rpm
# wget http://ftp.riken.jp/Linux/centos/4/os/i386/CentOS/RPMS/python-sqlite-1.1.7-1.2.1.i386.rpm
# wget http://ftp.riken.jp/Linux/centos/4/os/i386/CentOS/RPMS/python-urlgrabber-2.9.8-2.noarch.rpm


# rpm -ivh yum-2.4.3-1.c4.noarch.rpm python-elementtree-1.2.6-5.el4.centos.i386.rpm python-sqlite-1.1.7-1.2.1.i386.rpmpython-urlgrabber-2.9.8-2.noarch.rpm
 Re: centos4でのyumのインストール ( No.2 )
日時: 2007/08/21 19:56
名前: 田中

管理者様

お忙しい中ご回答ありがとうございます。
さっそくやってみましたが

# wget http://ftp.riken.jp/Linux/centos/4/os/i386/CentOS/RPMS/yum-2.4.3-1.c4.noarch.rpm



--03:49:46-- http://ftp.riken.jp/Linux/centos/4/os/i386/CentOS/RPMS/yum-2.4.3-1
.c4.noarch.rpm
      => `yum-2.4.3-1.c4.noarch.rpm'
Resolving ftp.riken.jp... 134.160.38.1
Connecting to ftp.riken.jp|134.160.38.1|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
03:49:46 ERROR 404: Not Found.

となりましてエラーになってしまいます。
私も最初
http://kajuhome.com/yum.shtml#n02
を参考に
# wget http://ftp.riken.jp/Linux/centos/4/os/i386/CentOS/RPMS/yum-2.4.3-1.c4.noarch.rpm
をおこなったのですが上記エラーになってしまったので
# wget http://ftp.riken.jp/Linux/centos/4/os/i386/CentOS/RPMS/yum-2.4.3-1.c4.noarch.rpm
をおこないました・・。

こういった場合はどのように対処致せばよろしいのでしょうか?
 Re: centos4でのyumのインストール ( No.3 )
日時: 2007/08/22 07:31
名前: 管理者

> # wget http://ftp.riken.jp/Linux/centos/4/os/i386/CentOS/RPMS/yum-2.4.3-1.c4.noarch.rpm
>
> が
>
> --03:49:46-- http://ftp.riken.jp/Linux/centos/4/os/i386/CentOS/RPMS/yum-2.4.3-1.c4.noarch.rpm
>       => `yum-2.4.3-1.c4.noarch.rpm'
> Resolving ftp.riken.jp... 134.160.38.1
> Connecting to ftp.riken.jp|134.160.38.1|:80... connected.
> HTTP request sent, awaiting response... 404 Not Found
> 03:49:46 ERROR 404: Not Found.
>
> となりましてエラーになってしまいます。


ファイル名、バージョンが誤っておりました。(失礼致しました)
以下に置き換えて実施してみてください。

# wget http://ftp.riken.jp/Linux/centos/4/os/i386/CentOS/RPMS/yum-2.4.3-3.el4.centos.noarch.rpm
 Re: centos4でのyumのインストール ( No.4 )
日時: 2007/08/22 20:54
名前: 田中

管理人様

お忙しい中ご回答ありがとうございます。
何度もすみません。

置き換えてやってみました。

# wget http://ftp.riken.jp/Linux/centos/4/os/i386/CentOS/RPMS/yum-2.4.3-3.el4.centos.noarch.rpm
# wget http://ftp.riken.jp/Linux/centos/4/os/i386/CentOS/RPMS/python-elementtree-1.2.6-5.el4.centos.i386.rpm
# wget http://ftp.riken.jp/Linux/centos/4/os/i386/CentOS/RPMS/python-sqlite-1.1.7-1.2.1.i386.rpm
# wget http://ftp.riken.jp/Linux/centos/4/os/i386/CentOS/RPMS/python-urlgrabber-2.9.8-2.noarch.rpm


rpm -ivh yum-2.4.3-3.el4.centos.noarch.rpm python-elementtree-1.2.6-5.el4.centos.i386.rpm python-sqlite-1.1.7-1.2.1.i386.rpm python-urlgrabber-2.9.8-2.noarch.rpm

すると再び下記のエラーが表示されました。

error: Failed dependencies:
    libsqlite3.so.0 is needed by python-sqlite-1.1.7-1.2.1.i386

どのように対処すればよろしいでしょうか?
 Re: centos4でのyumのインストール ( No.5 )
日時: 2007/08/22 22:37
名前: たう

「python-sqlite-1.1.7-1.2.1.i386にはlibsqlite3.so.0が必要です」
といっているのでインストールしてください
libsqlite3.so.0はsqlite-3.3.6-2.i386.rpmに入っています
 Re: centos4でのyumのインストール ( No.6 )
日時: 2007/08/23 20:36
名前: 田中

たう様 管理人様

お忙しい中丁寧にご回答ありがとうございます。

無事yumのインストール成功致しました。
ありがとうございました。

■ その他

ページ先頭へ


Copyright(©)2004-2018 First home server construction. All Right Reserved.