はじめての自宅サーバ構築 - Fedora/CentOS -
Last Update 2018/05/30
[ 更新履歴 ] [ サイト マップ ] [ 質問掲示板 ] [ 雑談掲示板 ] [ リンク ]
トップ >> 当サイト情報 >> スレッド

このページは表示専用です。新規投稿・レスや最新情報はこちらです。

 rpmでのインストールエラー
日時: 2006/09/16 19:13
名前: kyo   <kyo_r_s@yahoo.co.jp>

?不明点・障害内容:インストール不能
?ログの有無   :
  (有:その内容):
?Distribution  :
      Version:
?Service Name  :
      Version:
?ネットワーク構成:JDK1.5 64bit

管理者 様 
お世話になります。
「rpm -ivh tomcat5-5.5.17-3jpp_5fc.x86_64.rpm」 を実行すると
以下のえらーがでます。解決方法宜しくお願いいたします。


[root@fe kyo]# rpm -ivh tomcat5-5.5.17-3jpp_5fc.x86_64.rpm
警告: tomcat5-5.5.17-3jpp_5fc.x86_64.rpm: V3 DSA signature: NOKEY, key ID 30c9ecf8
エラー: Failed dependencies:
jakarta-commons-daemon >= 1.0 is needed by tomcat5-5.5.17-3jpp_5fc.x86_64
jakarta-commons-launcher >= 0:0.9 is needed by tomcat5-5.5.17-3jpp_5fc.x86_64
java-gcj-compat >= 1.0.31 is needed by tomcat5-5.5.17-3jpp_5fc.x86_64
jndi-ldap is needed by tomcat5-5.5.17-3jpp_5fc.x86_64
libgcj_bc.so.1()(64bit) is needed by tomcat5-5.5.17-3jpp_5fc.x86_64
rtld(GNU_HASH) is needed by tomcat5-5.5.17-3jpp_5fc.x86_64
tomcat5-common-lib = 0:5.5.17-3jpp_5fc is needed by tomcat5-5.5.17-3jpp_5fc.x86_64
tomcat5-server-lib = 0:5.5.17-3jpp_5fc is needed by tomcat5-5.5.17-3jpp_5fc.x86_64
xerces-j2 >= 0:2.7.1 is needed by tomcat5-5.5.17-3jpp_5fc.x86_64

■ コンテンツ関連情報

 Re: rpmでのインストールエラー ( No.1 )
日時: 2006/09/17 00:23
名前: two

 お世話になっております、twoです。
エラーメッセージのとおり、依存関係にあるパッケージもインストールする必要性があります。
以上、宜しくお願い致します。
 Re: rpmでのインストールエラー ( No.2 )
日時: 2006/09/17 02:39
名前: kyo   <kyo_r_s@yahoo.co.jp>

two 様
ご返事、有難うございます。
インタネットにはTomcatの64bitバージョンが見つからなかったため、
FedorCoreの64bitバージョンにあるTomcat64bitバージョンを
インストールしようと思ってますが、うまくできません。

FedorCoreのCDにある以下のパッケージを
CentOSにインストール方法がないですか。
宜しくおねがいいたします。

tomcat5-5.5.17-3jpp_5fc.x86_64.rpm
tomcat5-admin-webapps-5.5.17-3jpp_5fc.x86_64.rpm
tomcat5-common-lib-5.5.17-3jpp_5fc.x86_64.rpm
tomcat5-jasper-5.5.17-3jpp_5fc.x86_64.rpm
tomcat5-jasper-javadoc-5.5.17-3jpp_5fc.x86_64.rpm
tomcat5-jsp-2.0-api-5.5.17-3jpp_5fc.x86_64.rpm
tomcat5-jsp-2.0-api-javadoc-5.5.17-3jpp_5fc.x86_64.rpm
tomcat5-server-lib-5.5.17-3jpp_5fc.x86_64.rpm
tomcat5-servlet-2.4-api-5.5.17-3jpp_5fc.x86_64.rpm
tomcat5-servlet-2.4-api-javadoc-5.5.17-3jpp_5fc.x86_64.rpm
tomcat5-webapps-5.5.17-3jpp_5fc.x86_64.rpm
 Re: rpmでのインストールエラー ( No.3 )
日時: 2006/09/17 07:49
名前: Zenx

CDを持っているんだったら、全てのrpmを一ヶ所のフォルダにコピーする。
その後、rpm ivh 1.rpm 2.rpm 4.rpm とスペースで全部羅列する

これでインストールはできると思う。
でもCentOSに?? 何が起こるかわかりませんけど。
 Re: rpmでのインストールエラー ( No.4 )
日時: 2006/09/17 18:23
名前: kyo   <kyo_r_s@yahoo.co.jp>

Zenx 様
ご返事ありがとうございます。

?DVDの「RPMS」フォルダの中で、
Zenxさんがおっしゃっている通りに実行してみましたが、
エラーメッセージが変わってないです。

?エラーの中で先にインストールべき「依存関係にあるパッケージ」の
パッケージ名はどの部分ですか。

以上、宜しくお願いいたします。
 Re: rpmでのインストールエラー ( No.5 )
日時: 2006/09/18 04:52
名前: two
参照: http://www.two-wonderland.net/

 お世話になっております、twoです。
パッケージ名を見ると、これはFedora Core 5用のパッケージかな?
そうだとしますと、あくまでFC5用にコンパイルされている為、インストールが出来ない場合があります。
試しにSRPMからRPMを生成してみてはいかがでしょうか?

 ちなみに私もCentOSを使用しております。
CentOS 4.Xは、Fedora Core 3と非常に近いディストリビューションですので、
FC 3用のパッケージでしたら問題なく使用できます。
以上、宜しくお願い致します。
 Re: rpmでのインストールエラー ( No.6 )
日時: 2006/09/18 19:57
名前: kyo   <kyo_r_s@yahoo.co.jp>

two 様

ご意見有難うございます。

Fedora Core 3のCDにはtomcatパッケージがないそうです。
来週の土日にDVD-RWを直してから、
Fedora Core 4のtomcatパッケージを見るつもりです。

これからも宜しくお願いいたします。
 Re: rpmでのインストールエラー ( No.7 )
日時: 2006/09/19 01:27
名前: two
参照: http://www.two-wonderland.net/

 お世話になっております、twoです。

> Fedora Core 3のCDにはtomcatパッケージがないそうです。
> 来週の土日にDVD-RWを直してから、
> Fedora Core 4のtomcatパッケージを見るつもりです。


 ちと調べてみました。
Fedora Core 4にはtomcatの64Bit CPUのパッケージがありそうです。

http://ftp.riken.jp/Linux/fedora/core/4/x86_64/os/Fedora/RPMS/

まずは、依存関係にあるパッケージも含め、このtomcatを試してみてはいかがでしょうか?
それでもダメでしたら、以下のURLにSRPMがありますので、それを使用して自分の環境にあった
tomcatのRPMを生成してはいかがでしょうか?(リビルド)

http://ftp.riken.jp/Linux/fedora/core/4/x86_64/os/SRPMS/

以上、宜しくお願い致します。
 Re: rpmでのインストールエラー ( No.8 )
日時: 2006/09/20 00:18
名前: kyo

two 樣

毎度お世話になっております。

>【http://ftp.riken.jp/Linux/fedora/core/4/x86_64/os/Fedora/RPMS/
>
>まずは、依存関係にあるパッケージも含め、このtomcatを試してみてはいかがでしょうか?
>それでもダメでしたら、以下のURLにSRPMがありますので、それを使用して自分の環境にあった
>tomcatのRPMを生成してはいかがでしょうか?(リビルド)
>
>【http://ftp.riken.jp/Linux/fedora/core/4/x86_64/os/SRPMS/



上の【http://ftp.riken.jp/Linux/fedora/core/4/x86_64/os/Fedora/RPMS/
パッケージのインストールはできませんでした。
インストール失敗のエラーメッセージは下に貼り付いてる通です。
次は【http://ftp.riken.jp/Linux/fedora/core/4/x86_64/os/SRPMS/
のソースをリビルドしたいですが、
リビルドする手順を教えていただけませんか。

どうぞ宣しくお願いいたします。


ーーーーーーーーーーーーーーーーーーーーーーーーーーーーーー
[root@fe ~]# ls
Desktop
DiCE
tomcat5-5.0.30-5jpp_6fc.x86_64.rpm
tomcat5-admin-webapps-5.0.30-5jpp_6fc.x86_64.rpm
tomcat5-jasper-5.0.30-5jpp_6fc.x86_64.rpm
tomcat5-jasper-javadoc-5.0.30-5jpp_6fc.x86_64.rpm
tomcat5-servlet-2.4-api-5.0.30-5jpp_6fc.x86_64.rpm
tomcat5-servlet-2.4-api-javadoc-5.0.30-5jpp_6fc.x86_64.rpm
tomcat5-webapps-5.0.30-5jpp_6fc.x86_64.rpm
[root@fe ~]# rpm -ihv tomcat5-5.0.30-5jpp_6fc.x86_64.rpm tomcat5-admin-webapps-5.0.30-5jpp_6fc.x86_64.rpm tomcat5-jasper-5.0.30-5jpp_6fc.x86_64.rpm tomcat5-jasper-javadoc-5.0.30-5jpp_6fc.x86_64.rpm tomcat5-servlet-2.4-api-5.0.30-5jpp_6fc.x86_64.rpm tomcat5-servlet-2.4-api-javadoc-5.0.30-5jpp_6fc.x86_64.rpm tomcat5-webapps-5.0.30-5jpp_6fc.x86_64.rpm
警告: tomcat5-5.0.30-5jpp_6fc.x86_64.rpm: V3 DSA signature: NOKEY, key ID 4f2a6fd2
エラー: Failed dependencies:
    ant >= 0:1.6.2 is needed by tomcat5-5.0.30-5jpp_6fc.x86_64
    jaf >= 0:1.0.1 is needed by tomcat5-5.0.30-5jpp_6fc.x86_64
    jakarta-commons-beanutils >= 0:1.7.0 is needed by tomcat5-5.0.30-5jpp_6fc.x86_64
    jakarta-commons-collections >= 0:3.1 is needed by tomcat5-5.0.30-5jpp_6fc.x86_64
    jakarta-commons-dbcp >= 0:1.2.1 is needed by tomcat5-5.0.30-5jpp_6fc.x86_64
    jakarta-commons-digester >= 0:1.3 is needed by tomcat5-5.0.30-5jpp_6fc.x86_64
    jakarta-commons-el >= 0:1.0 is needed by tomcat5-5.0.30-5jpp_6fc.x86_64
    jakarta-commons-fileupload >= 0:1.0-1jpp is needed by tomcat5-5.0.30-5jpp_6fc.x86_64
    jakarta-commons-launcher >= 0:0.9 is needed by tomcat5-5.0.30-5jpp_6fc.x86_64
    jakarta-commons-logging >= 0:1.0.4 is needed by tomcat5-5.0.30-5jpp_6fc.x86_64
    jakarta-commons-modeler is needed by tomcat5-5.0.30-5jpp_6fc.x86_64
    jakarta-commons-pool >= 0:1.2 is needed by tomcat5-5.0.30-5jpp_6fc.x86_64
    java-1.4.2-gcj-compat >= 1.4.2.0-40jpp_16rh is needed by tomcat5-5.0.30-5jpp_6fc.x86_64
    java-sdk >= 1.4 is needed by tomcat5-5.0.30-5jpp_6fc.x86_64
    javamail >= 0:1.3 is needed by tomcat5-5.0.30-5jpp_6fc.x86_64
    jdbc-stdext is needed by tomcat5-5.0.30-5jpp_6fc.x86_64
    jndi is needed by tomcat5-5.0.30-5jpp_6fc.x86_64
    jndi-ldap is needed by tomcat5-5.0.30-5jpp_6fc.x86_64
    libgcj.so.6()(64bit) is needed by tomcat5-5.0.30-5jpp_6fc.x86_64
    mx4j >= 0:1.1.1 is needed by tomcat5-5.0.30-5jpp_6fc.x86_64
    puretls is needed by tomcat5-5.0.30-5jpp_6fc.x86_64
    regexp >= 0:1.3 is needed by tomcat5-5.0.30-5jpp_6fc.x86_64
    xerces-j2 >= 0:2.6.2 is needed by tomcat5-5.0.30-5jpp_6fc.x86_64
    struts11 = 0:1.1 is needed by tomcat5-admin-webapps-5.0.30-5jpp_6fc.x86_64
    ant >= 0:1.5.4 is needed by tomcat5-jasper-5.0.30-5jpp_6fc.x86_64
    jakarta-commons-collections >= 0:2.1 is needed by tomcat5-jasper-5.0.30-5jpp_6fc.x86_64
    jakarta-commons-el >= 0:1.0 is needed by tomcat5-jasper-5.0.30-5jpp_6fc.x86_64
    jakarta-commons-logging >= 0:1.0.3 is needed by tomcat5-jasper-5.0.30-5jpp_6fc.x86_64
    java-1.4.2-gcj-compat >= 1.4.2.0-40jpp_16rh is needed by tomcat5-jasper-5.0.30-5jpp_6fc.x86_64
    libgcj.so.6()(64bit) is needed by tomcat5-jasper-5.0.30-5jpp_6fc.x86_64
    xerces-j2 >= 0:2.6.0 is needed by tomcat5-jasper-5.0.30-5jpp_6fc.x86_64
    java-1.4.2-gcj-compat >= 1.4.2.0-40jpp_16rh is needed by tomcat5-servlet-2.4-api-5.0.30-5jpp_6fc.x86_64
    libgcj.so.6()(64bit) is needed by tomcat5-servlet-2.4-api-5.0.30-5jpp_6fc.x86_64
    jakarta-taglibs-standard >= 0:1.1.0 is needed by tomcat5-webapps-5.0.30-5jpp_6fc.x86_64
  Suggested resolutions:
    /home/buildcentos/CENTOS/en/4.0/x86_64/CentOS/RPMS/java-1.4.2-gcj-compat-1.4.2.0-27jpp.noarch.rpm
    /home/buildcentos/CENTOS/en/4.0/x86_64/CentOS/RPMS/java-1.4.2-gcj-compat-devel-1.4.2.0-27jpp.noarch.rpm
    /home/buildcentos/CENTOS/en/4.0/x86_64/CentOS/RPMS/libgcj4-4.0.2-14.EL4.x86_64.rpm
[root@fe ~]#
 Re: rpmでのインストールエラー ( No.9 )
日時: 2006/09/20 23:38
名前: kyo

two 樣

お世話になっております。
以下のようにリビルドしてみましたが、
リビルドできないです。
以上、ご意見お願いいたします。

ーーーーーーーーーーーーーーーーーーーーーーーーーーーーーーーーーーー

[root@fe ~]# ll
合計 3572
drwxr-xr-x 3 root root  4096 9月 20 22:00 Desktop
drwxrwxr-x 4 root root  4096 9月 19 23:28 DiCE
drwxr-xr-x 2 root root  4096 9月 19 23:54 tomcat
-rw-r--r-- 1 root root 3640405 9月 19 23:53 tomcat5-5.0.30-5jpp_6fc.src.rpm
You have new mail in /var/spool/mail/root
[root@fe ~]# rpm --rebuile tomcat5-5.0.30-5jpp_6fc.src.rpm
--rebuile: unknown option
[root@fe ~]# rpmbuild --rebuile tomcat5-5.0.30-5jpp_6fc.src.rpm
--rebuile: unknown option
[root@fe ~]#
 Re: rpmでのインストールエラー ( No.10 )
日時: 2006/09/21 03:38
名前: two
参照: http://www.two-wonderland.net/

 お世話になっております、twoです。

> --rebuile: unknown option

 エラーメッセージが示すとおり、「そのようなオプションはありません。」と言っています。
manコマンドなどで確認はされましたでしょうか?
作業の流れは下記のようになります。

 # rpm -ivh ./tomcat5-5.0.30-5jpp_6fc.src.rpm

 # cd /usr/src/redhat/SPECS/; pwd
 /usr/src/redhat/SPECS

 # rpmbuild -bb --target athlon ./XXX.spec

 rpmbuildのオプションの詳しい説明はmanなどを参照して下さい。
"XXX.spec"はtomcatのspecファイルを指定して下さい。
以上、宜しくお願い致します。
 Re: rpmでのインストールエラー ( No.11 )
日時: 2006/09/24 12:23
名前: kyo

two 樣
お世話になります。
ご意見有難う御座いました。
ご説明に従ってやって見ましたが、うまくできないです。
64ビットバージョンは取り敢えずほっといて、
java,tomcat,apacheの前部を
通常バージョンで試しようと想います。
これからもよろしくお願いします。

■ その他

ページ先頭へ


Copyright(©)2004-2018 First home server construction. All Right Reserved.