はじめての自宅サーバ構築 - Fedora/CentOS -
Last Update 2018/01/16
[ 更新履歴 ] [ サイト マップ ] [ 質問掲示板 ] [ 雑談掲示板 ] [ リンク ]
トップ >> 当サイト情報 >> スレッド

このページは表示専用です。新規投稿・レスや最新情報はこちらです。

このスレッドはクローズされています。記事の閲覧のみとなります。

 Mysqlバージョンを下げたい
日時: 2006/07/08 13:11
名前: kumasan

?不明点・障害内容:Mysqlバージョンを下げたい
?Distribution  :2.6.11-1.1369_FC4
?ネットワーク構成:YahooBB(ADSL12MB)+FC4

kumasanです。いつもお世話になっています。
今回は、xoopsの設定で悩んでいます。お力をお貸しください。
こちらのサイトを頼りに、Fedora Core4でサーバを設定したので
(http://kajuhome.com/)
今回は、xoopsのインストールに挑戦しています。
xoops(xoops-2.0.15-JP)には、Mysqlが必用とのことでこれも
こちらのサイトを参考にインストールをしております。
xoopsのインストールをしていくと、
最終近くだと思うのですか、
「データベース設定確認」で「次に」という画面を押下すると
真っ白な画面でとまってしまいます。
色々なサイト情報で調べていると、xoopsは、PHP5の場合
Mysqlのバージョンが4.1.xではうまくいかないので
4.0.xにバージョンを下げたらいい旨のコメントがありました。

そこで質問です
当方、mysqlのインストールは、こちらのサイトを参考にして
yumを利用してインストールしております。
その際、
mysql-4.1.20-1.FC4.1
がインストールされているのですが、4.0.xのバージョンに
下げるためにはどうしたらいいでしょうか


ただ、mysqlのインストール状況を下記コマンドでみると
次のようになっています

[root@linux ~]# rpm -qa | grep mysql
libdbi-dbd-mysql-0.7.1-3
php-mysql-5.0.4-10.5
mysql-4.1.20-1.FC4.1
mysqlclient10-3.23.58-6
mysql-server-4.1.20-1.FC4.1


なお、参考にならないかも知れませんが
PHPのバージョンは次のとおりです
php-5.0.4-10.5

よろしくお願いします。




■ コンテンツ関連情報

 Re: Mysqlバージョンを下げたい ( No.1 )
日時: 2006/07/09 05:29
名前: moja
参照: http://www.miraiarcs.com

はじめまして

MySQLのダウングレードは不必要です。
私のサイトは、FedoraCore 4 から、Fedora Core 5へアップグレード、
PHP 5.1.4
MySQL 5.0.21
Apache 2.2.0
で、XOOPS cube 2.0.15 が走っています。

ちなみに、XOOPSよりも設計が古い、
osCommerce やら Zen-Cart やらも問題なく動いています(非公開)。

MySQLのダウングレードを考えるより、php.ini の設定内容を見直してみてください。
それと、my.cnf。これはデフォルトを弄らない。
どうしてもダメっぽい時は、今度は httpd.conf または xoops.conf(作っていたら)を見直す。

XOOPS 2.0.15 は MySQLをダウングレードせずとも動きますよ。

どうしてもどうしても・・・な時は、
システムの安定性を考えて CentOS 4.2 とか最新 4.3 とかのほうがいいと思います。
こちらは、PHP4、MySQL4 です。Apacheも2.0.xxです。
 Re: Mysqlバージョンを下げたい ( No.2 )
日時: 2006/07/09 10:08
名前: kumasan

mojaさん

貴重なご意見ありがとうございました。
Mysqlのダウンロードをしなくて動作できることをお聞きして安心しました。

もう少し勉強をしてみます。
結果については後日報告させていただきます

話は別になりますが、

mojaさんのコメント欄にあった
http://www.miraiarcs.com
をみさせていただきました。
xoopsで作成されたものでしょうか?
すっきりとしてきれいでこのようなものができればいいなぁと見せていただきました。
ありがとうございました。


 Re: Mysqlバージョンを下げたい ( No.3 )
日時: 2006/07/09 22:51
名前: moja

頑張ってください!

>xoopsで作成されたものでしょうか?

そそ、2.0.15のXOOPSですよ。

対XOOPS の php.ini の内容に関しては、
http://xoops.sourceforge.jp/wiki/free/index?HOWTO%2F%A5%A4%A5%F3%A5%B9%A5%C8%A1%BC%A5%EB%2FLinux%2F3.PHP
ここに詳しく載ってます。
ブラウザ画面が真っ白になる原因は多々ありますが、ひとつは文字のエンコードだと思うので、mbstringまわりを確認してみてください。
何が悪いんだろう? というのは、/var/log/httpd/error_log を参照して判断する材料にしてみてください。

ちなみに、私がやっちまった失敗談
FedoraCore 4 に XOOPS 2.0.13
php.ini で EUC-JP を指定しておいて、my.cnf にもEUC-JPのエンコードを入れたところ、登録(投稿)する文字に文字化けが起こった。
というわけで、弄るのは php.ini だけでいいようです。
 Re: Mysqlバージョンを下げたい ( No.4 )
日時: 2006/07/12 20:40
名前: kumasan

moja様
kumasanです。
遅くなりましたが、PHP・Mysqlともに元のバージョンのまま
XOOPSの設定ができました。
ありがとうございました。
原因は
moja様ご指摘のとおり、PHP.iniのところでした。
これから、ゆっくりとXOOPSの中身の設定です。
日々、勉強しながら、設定をしていきます
ありがとうございました。

■ その他

ページ先頭へ


Copyright(©)2004-2018 First home server construction. All Right Reserved.