はじめての自宅サーバ構築 - Fedora/CentOS -
Last Update 2018/01/16
[ 更新履歴 ] [ サイト マップ ] [ 質問掲示板 ] [ 雑談掲示板 ] [ リンク ]
トップ >> 当サイト情報 >> スレッド

このページは表示専用です。新規投稿・レスや最新情報はこちらです。

このスレッドはクローズされています。記事の閲覧のみとなります。

 yum updateでアップデートできません
日時: 2006/06/08 16:45
名前: まき

いつも拝見させてもらい、とても重宝しております。

昨日から何度も試しているんですがアップデートが出来ずに困っています。
私の設定にどこか不備があるのでしょうか?
ご教授くださいませ。

# yum update
   :
   :
 〜 省略 〜
   :
   :
--> Running transaction check
--> Processing Dependency: libecal-1.2.so.3 for package: gnome-panel
--> Processing Dependency: libecal-1.2.so.3 for package: evolution-webcal
--> Processing Dependency: libecal-1.2.so.3 for package: evolution
--> Processing Dependency: libecal-1.2.so.3 for package: evolution-connector
--> Processing Dependency: libedata-cal-1.2.so.1 for package: evolution-connector
--> Processing Dependency: libecal-1.2.so.3 for package: evolution-sharp
--> Finished Dependency Resolution
Error: Missing Dependency: libecal-1.2.so.3 is needed by package gnome-panel
Error: Missing Dependency: libecal-1.2.so.3 is needed by package evolution-webcal
Error: Missing Dependency: libecal-1.2.so.3 is needed by package evolution
Error: Missing Dependency: libecal-1.2.so.3 is needed by package evolution-connector
Error: Missing Dependency: libedata-cal-1.2.so.1 is needed by package evolution-connector
Error: Missing Dependency: libecal-1.2.so.3 is needed by package evolution-sharp


この様な状態です。

■ コンテンツ関連情報

 Re: yum updateでアップデートできません ( No.1 )
日時: 2006/06/08 16:54
名前: 管理者

依存関係のメッセージですね。
libecalが各々(メッセージ表示されているパッケージ)で必要と出ていますが、当方で確認した所、「libecal-1.2.so.3」は「/usr/lib/」に存在しています。
恐らく、「evolution-data-server」パッケージを作成する際に依存関係の指定ミスでしょう・・・
近い内に改善されると思いますよ。

ちなみに、「yum update」では他のパッケージもアップデートされている場合、上記のエラーにより更新する事が出来ません。
今回対象の「evolution-data-server」を外す事により、他を更新する事が出来ます。

以下コマンドを実施して下さい。

# yum update --exclude=evolution-data-server
 Re: yum updateでアップデートできません ( No.2 )
日時: 2006/06/09 09:51
名前: moja

余談ですが、evolution といえば、Linux版 Outlook。
Linux機でメールを見る、スケジュール管理をする、アドレスを管理をする…みたいな、
デスクトップPC的用途じゃなかったら、抜いてもいいと思いますよ。
メールだけならThunderbird(だったかな<スペル)で見れるし、
そもそもサーバ用途だったら間違いなく使わない。

moja家では、1号機(FC5x86_64)と2号機(CentOS4.3-i386)がGNOME、3号機(FC5-i386)がKDEですが、
扱いやすくするためにGUIを入れてはいますが、どれもデスクトップ環境は最小限に絞ってます。
入れても使わないし(^^ゞ
 Re: yum updateでアップデートできません ( No.3 )
日時: 2006/06/09 15:44
名前: まき

管理人さま。mojaさま。

ご返事いただきましてありがとうございます。

# yum update --exclude=evolution-data-server でアップデイトできました!!
間違って公開されてしまう事もあるんですね?私みたいな初心者では自分がなにを悪い事しちゃったんだろう?ってずいぶん悩みました。(こんな事もあるんですね。)

2・3日たったら、evolution-data-server も確認してみたいと思います。

本当にありがとうございました。

■ その他

ページ先頭へ


Copyright(©)2004-2018 First home server construction. All Right Reserved.