はじめての自宅サーバ構築 - Fedora/CentOS -
Last Update 2018/05/30
[ 更新履歴 ] [ サイト マップ ] [ 質問掲示板 ] [ 雑談掲示板 ] [ リンク ]
トップ >> 当サイト情報 >> スレッド

このページは表示専用です。新規投稿・レスや最新情報はこちらです。

このスレッドはクローズされています。記事の閲覧のみとなります。

 文字化けがなおらない・・・
日時: 2006/05/04 21:59
名前: 初心者

過去ログを参照して試してみましたが、
それでもできなかったので質問させてください。
Fedora Core 5を使用しています。
/etc/sysconfig/i18nを以下のように変更しました。

LANG="ja_JP.eucJP"
SUPPORTED="ja_JP.eucJP:ja_JP:ja"
SYSFONT="latarcyrheb-sun16"

このように記述して変更を保存しましたが、なぜか文字化けが直りません。
(UTF-8のときとは、また別の文字に文字化けしています。)
もちろんkonは試しています。

ただ、GUIモードにしたときのGNOME端末から行うと正常に表示されます。(「文字コードの設定」をEUC-JPに)

CUIモードでも文字化けしないようにするにはどうすれば良いでしょうか?
また、文字コードにShift-JISを使用することはできないでしょうか?
よろしくお願い致します。

■ コンテンツ関連情報

 Re: 文字化けがなおらない・・・ ( No.1 )
日時: 2006/05/05 10:34
名前: 管理者

Fedora Core 5では「/etc/sysconfig/i18n」の内容は以下のみ、だったと思います。
LANG="ja_JP.UTF-8"

余り余計な設定を付加すると嵌ってしまう事があるので、まず上記だけにしてみてください。

また、変更後は再起動されましたよね?

文字化けしているのは、コンソール上ですか?
それとも、クライアント端末からのターミナル上ですか?
 Re: 文字化けがなおらない・・・ ( No.2 )
日時: 2006/05/05 14:49
名前: 私も初心者   <ju_hi_mail@yahoo.co.jp>

飛び入り書き込みすみません。
実は私も同じような文字化けの障害で困っていたところでした。
使用しているのはTurboLinuxなのです。
しかし、Gnomeのターミナルで見ると表示されるのに
ローカルのCUI画面やteraterm上で見ると文字化けしていましたが、
下記の
/etc/sysconfig/i18n に LANG="ja_JP.UTF-8" のみを入力し再起動したところ
文字化けが直りました。

管理者さんの書き込みのおかげで助かりました。
ありがとうございます。
 Re: 文字化けがなおらない・・・ ( No.3 )
日時: 2006/05/05 16:28
名前: 初心者

LANG="ja_JP.UTF-8"
のみ記述して、再起動してみましたが、なおりませんでした。
日本語になるはずの文字が全て■になってしまいました。

よくわかりませんが、
日付や「そのようなファイルやディレクトリはありません。」や
「*** を起動中: [ OK ]」というのが文字化けします。
また、setupを開いたときにも文字化けしています。
たぶんコンソール上のような気がします。

日本語入力もできないんですよね、CUIだと・・・。
 Re: 文字化けがなおらない・・・ ( No.4 )
日時: 2006/05/05 16:47
名前: 管理者

上記の状態で、kon実行後に文字化けしてしまうのでしょうか?

> たぶんコンソール上のような気がします。
Linux端末のディスプレイをコンソールと呼んでいます。
Windows上などのリモート端末からLinuxへログインした「TeraTerm」や「PuTTY」をターミナルと呼んでいます。
文字化けを起こしているのは前者の方ですよね?

>>私も初心者さん
良かったですね。意外と質問者以外の方にも役立っているなんて喜ばしい限りです。
 Re: 文字化けがなおらない・・・ ( No.5 )
日時: 2006/05/05 16:52
名前: 初心者

konももちろん試しています。
やはりうちの環境が悪いんでしょうか・・・。
 Re: 文字化けがなおらない・・・ ( No.6 )
日時: 2006/05/05 16:55
名前: 管理者

# env | grep LANG

上記コマンド結果は「/etc/sysconfig/i18n」の「LANG」と同様になっていますか?
 Re: 文字化けがなおらない・・・ ( No.7 )
日時: 2006/05/05 17:46
名前: 初心者

LANG=ja_JP.UTF-8
と表示されました。
記述した内容と同じです。
 Re: 文字化けがなおらない・・・ ( No.8 )
日時: 2006/05/05 17:57
名前: 管理者

設定自体には問題なさそうですね。他に、思い当たる事がないのですが・・・

ちなみに「Shift-JIS」にするには、以下のURLで可能かもしれません。
ただし、RedHatですが・・

http://www.jp.redhat.com/FAQ/index_support_2.html#19

 Re: 文字化けがなおらない・・・ ( No.9 )
日時: 2006/05/05 18:07
名前: 初心者

何度も再インストールして試してみましたが、だめでした。
意味がないかもしれませんが、一度、FC4を入れて試してみます。
それでもだめでしたら、他のLinuxで試してみます・・・。
 Re: 文字化けがなおらない・・・ ( No.10 )
日時: 2006/05/07 14:25
名前: 初心者

FC4をいれて試してみました。
/etc/sysconfig/i18nを編集し、kon実行後
問題なく日本語で表示されました。
FC5のバグなんでしょうかね?
 Re: 文字化けがなおらない・・・ ( No.11 )
日時: 2006/05/07 17:22
名前: 管理者

変な現象ですね・・・

当方は、問題なく表示できているのですが・・・
 Re: 文字化けがなおらない・・・ ( No.12 )
日時: 2006/05/14 01:39
名前: 初心者

追記なのですが、FC5でkon実行後にこのようなエラーがでていました。

audit(1147537913.654:2): avc: { execmod } for pid=2260 comm="kon" name
="kon" dev=dm-0 ino=866678 scontext=root:system_r:unconfined_t:s0-s0:c0.c255 tco
ntext=system_u:object_r:bin_t:s0 tclass=file
lon: error while loading shared libraries: cannot restore segment prot after rel
oc: Permission denied

読み込みできていないのが原因ようですが・・・。
 Re: 文字化けがなおらない・・・ ( No.13 )
日時: 2006/12/10 00:15
名前: koikoi

はじめまして、
当方本日、富士通のPCにFedoraCore6をインストールしましたが、「漢字」のところだけ文字化けします。

/etc/sysconfig/i18n に LANG="ja_JP.UTF-8" のみを入力をし再起動しても直りません。

最初のインストールはGUIで出来ませんでした。何回やってもTXTインストールの画面になります。
再起動しても必ず、TXTでのログインになります。毎回/sbin/telinit 6を入力しないと
GUIになりません。カタカナは正常に表示されていますが、これは、また再インストール
しかないのでしょうか?

初心者で質問の仕方が良くなく、ご迷惑お掛けしますが、教えてください。
 Re: 文字化けがなおらない・・・ ( No.14 )
日時: 2006/12/10 08:35
名前: ZERO

>当方本日、富士通のPCにFedoraCore6をインストールしましたが、「漢字」のところだけ文字化けします。

文字化けは別問題ですけど、富士通・NEC等は純粋なM/Bやグラフィックカードを使用していない(独自のものや手を加えている)ものが多いので、インストールできただけでもラッキーですよ。
販売されている3割位がなんらかのトラブルに見舞われます。

僕も富士通PCを4台所持していますが全滅です。なぜか”SUSE”はインストールできたけど。

>再起動しても必ず、TXTでのログインになります。毎回/sbin/telinit 6を入力しないと
>GUIになりません。カタカナは正常に表示されていますが、これは、また再インストール
>しかないのでしょうか?


/sbin/telinit 6 を実行する前に”/var/log/messages”ファイルに何かエラーがでてませんか?
あと、”dmsg”を実行するとメッセージが表示されるので何かの読み込みが失敗してるとか?
”dmsg > dmsg.txt”とすれば、ファイルに書き込まれるので後からゆっくりと見ることができます。
 Re: 文字化けがなおらない・・・ ( No.15 )
日時: 2006/12/10 13:44
名前: koikoi

ZERO様
ご回答有難う御座います。そうなんですか、富士通やNECは基本的に無理に近いんですね。
当方3回インストールを試みました。2回目はディスク2を入れ変えたとたんに文字化けで
先に進めませんでした。

/sbin/telinit 6 を実行する前に”/var/log/messages”ファイルに何かエラーがでてませんか?
あと、”dmsg”を実行するとメッセージが表示されるので何かの読み込みが失敗してるとか?
”dmsg > dmsg.txt”とすれば、ファイルに書き込まれるので後からゆっくりと見ることができます。

上記についてですが、”/var/log/messages”をすると”そのようなファイルやディレクトリはありません”
と表示されました。また、”dmsg”は”not found”です。

と言うことは、まともにインストールされていないんですね!
これから、いろいろ調べて再チャレンジします。

有難う御座いました。

■ その他

ページ先頭へ


Copyright(©)2004-2018 First home server construction. All Right Reserved.