はじめての自宅サーバ構築 - Fedora/CentOS -
Last Update 2018/01/16
[ 更新履歴 ] [ サイト マップ ] [ 質問掲示板 ] [ 雑談掲示板 ] [ リンク ]
トップ >> 当サイト情報 >> スレッド

このページは表示専用です。新規投稿・レスや最新情報はこちらです。

 Tripwireの設定エラー
日時: 2005/02/10 23:09
名前: ryam

Tripwireのポリシーファイルを作るときに、
スクリプトを使うと以下のようにエラーがでて、
うまくスクリプトファイルを作ることができません。
調べても力不足なものでいまいち……。
どのようにしたら解決できるでしょうか。
[root@**** root]# /etc/tripwire/twpolmake.pl /etc/tripwire/twpol.txt > /etc/tripwire/twpol.txt.out
/etc/tripwire/twpolmake.pl: line 1: pwire: command not found
/etc/tripwire/twpolmake.pl: line 20: =[0]: command not found
/etc/tripwire/twpolmake.pl: line 22: syntax error near unexpected token `POL,"$POLFILE"'
/etc/tripwire/twpolmake.pl: line 22: `open(POL,"$POLFILE") or die "open error: $POLFILE" ;'

■ コンテンツ関連情報

 Re: Tripwireの設定エラー ( No.1 )
日時: 2005/02/11 05:13
名前: T_T

ryam 様

答えを聞くとあまりにも簡単ですよ。

[root@linux root]# vi /etc/tripwire/twpolmake.pl

としたときに、コマンドモードから編集モードに変わっていないのにコピーしたからです。
ちゃんと i を押してからコピーすれば大丈夫だったはずです。
なので、

[root@linux root]# rm -f /etc/tripwire/twpolmake.pl
[root@linux root]# vi /etc/tripwire/twpolmake.pl

として、i を押してから該当部分をコピーすれば大丈夫です。
たぶん、これは誰もが一度はするミスだと思いますよ。
 Re: Tripwireの設定エラー ( No.2 )
日時: 2005/02/11 22:07
名前: ryam

T_T様、ありがとうございます。
と、思ったら早速別のエラーが。
[root@linux root]# /etc/tripwire/twpolmake.pl /etc/tripwire/twpol.txt > /etc/tripwire/twpol.txt.out
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LANG = "en_US.eucJP"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
パール……場所?と思い、パールの場所を確認。
.plのファイルで指定している場所と違ってたので修正。
でもまた同じエラーが……orz
 Re: Tripwireの設定エラー ( No.3 )
日時: 2005/02/12 06:33
名前: T_T

ryam 様

たまにそういうエラーがでる環境があるようですね。
どこかが何かおかしいんでしょうね。

回避方法です。

[root@linux root]# vi /root/.cshrc

としてやって、最終行に

PERL_BADLANG=0; export PERL_BADLANG

を追記してください。
ログインし直すとエラーは出なくなると思います。
 Re: Tripwireの設定エラー ( No.4 )
日時: 2005/02/12 14:45
名前: ryam

T_T様
エラーは回避できました。
インストール時の設定を間違えたかな。
言語設定かなんかがおかしいのかと思います。
[root@linux root]# cat /etc/sysconfig/i18n
LANG="en_US.eucJP" ←ここが不審
SUPPORTED="ja_JP.eucJP:ja_JP:ja"
SYSFONT="latarcyrheb-sun16"

いろいろ調べてみようと思います。
どうもありがとうございました。
 Re: Tripwireの設定エラー ( No.5 )
日時: 2005/02/13 19:50
名前: T_T

ryam 様

言語設定はおかしいですね。
/etc/sysconfig/i18n を書き換えて見てください。

LANG="en_US.eucJP"
   ↓
LANG="ja_JP.eucJP"

一度ログアウトして再度ログインしてやると反映されます。

■ その他

ページ先頭へ


Copyright(©)2004-2018 First home server construction. All Right Reserved.