はじめての自宅サーバ構築 - Fedora/CentOS -
Last Update 2018/01/16
[ 更新履歴 ] [ サイト マップ ] [ 質問掲示板 ] [ 雑談掲示板 ] [ リンク ]
トップ >> 当サイト情報 >> スレッド

このページは表示専用です。新規投稿・レスや最新情報はこちらです。

このスレッドはクローズされています。記事の閲覧のみとなります。

 アイコンが表示されない<AWStats>
日時: 2005/01/03 03:51
名前: ももんが

明けましておめでとうございます。早速ですが暮れから取組んでいる<AWStats>のセットアップがうまくいきません。アドバイス等ありましたらお願いします。

<不具合状況>

(1)AWStatsはインストール済み。クライアントから解析したページを閲覧するとアイコンや棒グラフが表示されていない。不思議なことにサーバーマシンにて同ページへアクセスするとアイコンや棒グラフは表示されている。
(2)/etc/awstats.xxx.conf の関係しそうな箇所の設定は以下の通りで実際にそのディレクトリにアイコンを置いている。
   DirIcons="/web/xxx/html/icon"
また表示されていないアイコンの代わりにバツマーク(×)が表示されていますが、ここを右クリックしプロパティーを確認すると上記で設定したパスと同じパスが確認出来る。
(3)同一LAN内にサーバーの他にクライアントが2台あり。両方共WinXP_SP2のDOS/Vマシン。解析結果を見る際はLAN外部のプロキシサーバーよりアクセスしています。両方のクライアントにて同じ現象が発生している。サーバーマシンはFedoraCore2を使用しています。

以上ですがなにか思い当たる節があればお願いします。綺麗なグラフィックなソフトですので是非ともきっちりインストールをしたいと思っています。宜しくお願いします。

■ コンテンツ関連情報

 Re: アイコンが表示されない<AWStats> ( No.1 )
日時: 2005/01/03 09:26
名前: 管理者

明けましておめでとうございます。本年も宜しくお願い致します。

サーバ上で閲覧した場合には正常に表示されるらしいので、関係ないとは思いますが思い当たる部分を列挙させて頂きます。

(1)apache設定ファイル(httpd.conf)にて
   ? awstatsインストール時に自動的に追加設定される部分のパスに問題がないか?
     awstatsが参照するアイコンパスが設定されているか?
     (下記は当サイトの場合です。)
     Alias /awstatsclasses "/usr/local/awstats/wwwroot/classes/"
     Alias /awstatscss "/usr/local/awstats/wwwroot/css/"
     Alias /awstatsicons "/usr/local/awstats/wwwroot/icon/"
   ? awstatsのディレクトリが内部参照のみになっていないか?
     (<Directory "/usr/local/awstats/wwwroot">の部分)
     awstats自体が見えているので、ここは関係ないと思いますが・・・
(2)プロキシサーバを疑う
   ? プロキシサーバのキャッシュを一度すべて初期化してみる。
     プロキシサーバを再起動すれば可能?
   ? 可能であればプロキシサーバを外した状態でサーバにアクセスしてみる。

ももんが様の場合は、サーバ上でアイコン等が見えている状態なので、どうもプロキシサーバが影響を与えている様に感じられます。

後、WinXP_SP2になってからアイコンやポップアップウィンドウの抑止機能が追加されているので、クライアント自体を疑ってみては如何でしょうか?
 Re: アイコンが表示されない<AWStats> ( No.2 )
日時: 2005/01/04 01:51
名前: ももんが

回答ありがとうございました。アイコンが表示される様になりました。もう半ばAWStatsの搭載は諦めていたのですが管理人さんのレスに勇気づけられもうちょっと頑張ってみて良かったです。

結局/etc/awstats.xxx.confの中の <DirIcons="/web/xxx/html/icon">という所が悪さをしていました。この設定を<DirIcons="http://自分のサーバー名/icon">と書き換えたところ問題解決しました。

推測ですが通常では/var/www/html以下にhtmlファイル(ホームページのファイル)を置くと問題が発生しない様ですが 自分の場合バーチャルホストを設置している関係上 /web/xxx/htmlの下にAWStatsのiconディレクトリを置いてしまったのでこの様な事態に陥ってしまった様です。

初めて自分のホームページが公開出来た時も感動しましたが 今回もその時と同じ様に感動しました。(もう目がウルウルです)

それではまた宜しくお願いします。
 Re: アイコンが表示されない<AWStats> ( No.3 )
日時: 2005/01/04 08:30
名前: 管理者

こちらこそ、貴重な情報を有り難うございます。

バーチャルホストを構築するとそのような現象になってしまうんですね。
パスだけの問題かもしれませんが・・・

当方はバーチャルホストにしていないので、全く未知の問題でしたが何よりも解決できて良かったです。

あまりお力になれませんでしたが、此方こそ、また宜しくお願い致します。

■ その他

ページ先頭へ


Copyright(©)2004-2018 First home server construction. All Right Reserved.