はじめての自宅サーバ構築 - Fedora/CentOS -
Last Update 2018/01/16
[ 更新履歴 ] [ サイト マップ ] [ 質問掲示板 ] [ 雑談掲示板 ] [ リンク ]
トップ >> 当サイト情報 >> スレッド

このページは表示専用です。新規投稿・レスや最新情報はこちらです。

このスレッドはクローズされています。記事の閲覧のみとなります。

 centos 5.4 update エラーについて
日時: 2010/01/07 21:59
名前: 卵焼き

1.不明点・障害内容:yum update Transaction Check Error:
2.ログの有無   :有
  (有:その内容) :
3.Distribution  :centos
      Version :5.4
4.Service Name  :
      Version :
5.ネットワーク構成:
'09/12/27頃だと思いますが、updateの通知が表示されたので、update(GUI)をしたところ、エラーでupdateできませんでした。メッセージ上ではpython-pycurlが衝突して処理エラーが起きているように見えます。
 どなたか対処・原因等を御教授お願いしたく、投稿させていただきました。
使用機器:thinkpad R60e(0658-DJJ)
OS : centos 5.4(デスクトップ用途)
です。下記にコマンドラインでの結果抜粋を示します。
みずらくてすみません。
-----------ここから----------
#yum update
Dependencies Resolved
========================================================================
Package Arch Version Repository Size
========================================================================
Updating:
bzr i386 2.0.3-1.el5.rf rpmforge 11 M
lftp i386 4.0.5-1.el5.rf rpmforge 2.1 M
perl-Compress-Raw-Zlib i386 2.023-1.el5.rf rpmforge 169 k
syslinux i386 3.84-1.el5.rf rpmforge 1.5 M
Installing for dependencies:(依存のためインストールします)
python-curl i386 7.15.5-1.2.el5.rf rpmforge 100 k
Transaction Summary
========================================================================
Install 1 Package(s)
Update 4 Package(s)
Remove 0 Package(s)
Total size: 15 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test

Transaction Check Error:
file /usr/lib/python2.4/site-packages/pycurl.so from install of python-curl-7.15.5-1.2.el5.rf.i386 conflicts with file from package python-pycurl-7.15.5.1-4.el5.i386
Error Summary

■ コンテンツ関連情報

 Re: centos 5.4 update エラーについて ( No.1 )
日時: 2010/01/08 10:44
名前: DJ OZMAN

http://www.hot-linux.org/tree.php
レスがつかないからって
マルチポスト反対
 Re: centos 5.4 update エラーについて ( No.2 )
日時: 2010/01/08 15:17
名前: stranger
参照: http://ja.528p.com/

rpmforgeのパッケージとCentOSのパッケージとどちらを必要としているかを考える
rpmforgeがサードパーティなのだから python-curlを入れないようしたほうが
個人的には良いと思う
python-pycurlは簡単に削除できないと思う

bzr
lftp
perl-Compress-Raw-Zlib
syslinux
のどれかがpython-curlを必要としているのでしょうが

手動で上記のrpmパッケージをダウンロードして
rpmコマンドでアップデートしてみる
python-curlを必要とするものを一時的にアップデートしないようにyumを設定する

ヒント yum exclude でnet検索してください
 Re: centos 5.4 update エラーについて ( No.3 )
日時: 2010/01/11 10:32
名前: 卵焼き

 返信ありがとうございます。
DJ OZMAN さん、
  マルチポスト(というんですね)しました。
このような場に対してのマナーが良く分かっていないものでしました。マルチポスト反対
と書かれていたので、その理由は、情報が沢山重複してしまうという理由なのかな?と解釈しました。
もし、アドバイス頂けたら幸いです。申し訳ありません。

stranger さん、
 ありがとうございます。
 centosを個人レベルで使用してまして、使用目的はEDAベンダツールをlinuxで使用してみたいと思い、
ツールの動作保証しているred hatクローンのcentosを選びました。導入方法はインタネットで調べながら、
見様見真似で行っており、今まで、このような現象になったことがありませんでした。
対処としましては、
/etc/yum.repos.d/rpmforge.repo にて,
enable=1
 ↓
enable=0
に修正しました。(途中からなので、今後、問題出るかもしれませんが・・・)

 red hatクローンとして使用するのであれば、"stranger"さんの御指摘の通り、
rpmforgeを入れない方がよいということがわかりました。
 このエラーがでなければ、気がつきませんでした(笑)

 "yum exclude"調べてみます。ありがとうございました。
 Re: centos 5.4 update エラーについて ( No.4 )
日時: 2010/01/11 13:59
名前: stranger
参照: http://ja.528p.com/

rpmforgeはCentOSに含まれないパッケージを多数配布されていて
有用なサイトですが、天才にも間違いがあるということです
メインとコンフリクトしないようにパッケージをつくるべきなのです
そのうち改善されるでしょうから、一時的にupdateしないように
excludeで除外しておきます
 Re: centos 5.4 update エラーについて ( No.5 )
日時: 2010/01/13 20:57
名前: 卵焼き

 strangerさん

 アドバイスありがとうございました。
excludeの方で対処したいと思います。

■ その他

ページ先頭へ


Copyright(©)2004-2018 First home server construction. All Right Reserved.