はじめての自宅サーバ構築 - Fedora/CentOS -
Last Update 2018/01/16
[ 更新履歴 ] [ サイト マップ ] [ 質問掲示板 ] [ 雑談掲示板 ] [ リンク ]
トップ >> 当サイト情報 >> スレッド

このページは表示専用です。新規投稿・レスや最新情報はこちらです。

このスレッドはクローズされています。記事の閲覧のみとなります。

 YUM実行時に表示されたErrorについて
日時: 2009/07/31 12:02
名前: 勝美

先日訳あってサーバーを10日間程度止めました。
そして再度立ち上げて、YUMのアップデートを実行したところ、
下記のErrorらしきものが表示されています。

今のところ、サーバー自体に障害は出ていません。


1.不明点・障害内容:
yum update実行時のErrorについて

2.ログの有無   :
  (有:その内容) :
[root@****.com ~]# yum -y update
Loaded plugins: downloadonly, fastestmirror, priorities
Loading mirror speeds from cached hostfile
* rpmforge: apt.sw.be
* base: ftp.riken.jp
* updates: ftp.riken.jp
* addons: ftp.riken.jp
* extras: ftp.riken.jp
395 packages excluded due to repository priority protections
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package amavisd-new.i386 0:2.6.4-2.el5.rf set to be updated
--> Processing Dependency: perl(Mail::DKIM) for package: amavisd-new
--> Processing Dependency: p7zip for package: amavisd-new
--> Processing Dependency: perl(Crypt::OpenSSL::RSA) for package: amavisd-new
---> Package python-devel.i386 0:2.4.3-24.el5_3.6 set to be updated
---> Package python.i386 0:2.4.3-24.el5_3.6 set to be updated
---> Package bind-libs.i386 30:9.3.4-10.P1.el5_3.3 set to be updated
---> Package libtiff.i386 0:3.8.2-7.el5_3.4 set to be updated
---> Package nspr.i386 0:4.7.4-1.el5_3.1 set to be updated
---> Package bind-utils.i386 30:9.3.4-10.P1.el5_3.3 set to be updated
---> Package firefox.i386 0:3.0.12-1.el5.centos set to be updated
---> Package nss.i386 0:3.12.3.99.3-1.el5.centos.2 set to be updated
---> Package nss-tools.i386 0:3.12.3.99.3-1.el5.centos.2 set to be updated
---> Package xulrunner.i386 0:1.9.0.12-1.el5 set to be updated
---> Package libtiff-devel.i386 0:3.8.2-7.el5_3.4 set to be updated
--> Running transaction check
---> Package p7zip.i386 0:4.61-1.el5.rf set to be updated
---> Package perl-Mail-DKIM.noarch 0:0.36-1.el5.rf set to be updated
--> Processing Dependency: perl(Digest::SHA) for package: perl-Mail-DKIM
---> Package perl-Crypt-OpenSSL-RSA.i386 0:0.25-1.el5.rf set to be updated
--> Running transaction check
---> Package perl-Digest-SHA.i386 0:5.47-1.el5.rf set to be updated
--> Processing Dependency: /usr/lib/python2.4 for package: gamin-python
--> Processing Dependency: /usr/lib/python2.4 for package: libxml2-python
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package bind-sdb.i386 30:9.3.4-10.P1.el5_3.1 set to be updated
--> Processing Dependency: bind = 30:9.3.4-10.P1.el5_3.1 for package: bind-sdb
--> Processing Dependency: bind-utils = 30:9.3.4-10.P1.el5_3.1 for package: bind-sdb
--> Running transaction check
---> Package bind-sdb.i386 30:9.3.4-10.P1.el5_3.1 set to be updated
--> Processing Dependency: bind-utils = 30:9.3.4-10.P1.el5_3.1 for package: bind-sdb
---> Package bind.i386 30:9.3.4-10.P1.el5_3.1 set to be updated
--> Processing Dependency: bind-libs = 30:9.3.4-10.P1.el5_3.1 for package: bind
--> Finished Dependency Resolution
30:bind-9.3.4-10.P1.el5_3.1.i386 from updates has depsolving problems
 --> Missing Dependency: bind-libs = 30:9.3.4-10.P1.el5_3.1 is needed by package 30:bind-9.3.4-10.P1.el5_3.1.i386 (updates)
30:bind-sdb-9.3.4-10.P1.el5_3.1.i386 from updates has depsolving problems
 --> Missing Dependency: bind-utils = 30:9.3.4-10.P1.el5_3.1 is needed by package 30:bind-sdb-9.3.4-10.P1.el5_3.1.i386 (updates)
Error: Missing Dependency: bind-utils = 30:9.3.4-10.P1.el5_3.1 is needed by package 30:bind-sdb-9.3.4-10.P1.el5_3.1.i386 (updates)
Error: Missing Dependency: bind-libs = 30:9.3.4-10.P1.el5_3.1 is needed by package 30:bind-9.3.4-10.P1.el5_3.1.i386 (updates)

3.Distribution  :
      Version :
CentOS release 5.3 (Final)


どうぞ、上記に表示されているError: Missingのアドバイスをお願いいたします。

■ コンテンツ関連情報

 Re: YUM実行時に表示されたErrorについて ( No.1 )
日時: 2009/07/31 12:09
名前: ken@CentOS

yum clean allを実行しリトライ
 Re: YUM実行時に表示されたErrorについて ( No.2 )
日時: 2009/07/31 12:13
名前: 勝美

ken@CentOSさん

アドバイスありがとうございます。
今は職場ですので、帰宅後に即実行してみます。
時間が取れれば、間で試しに戻ってみます。

また状況を投稿しますので、どうぞよろしくお願いします。
 Re: YUM実行時に表示されたErrorについて ( No.3 )
日時: 2009/07/31 12:56
名前: 勝美

ken@CentOSさん

ただいま帰宅して実行してみました。

> [root@****.com ~]# yum clean all
> Loaded plugins: downloadonly, fastestmirror, priorities
> Cleaning up Everything
> Cleaning up list of fastest mirrors


上記を実行後に再度、yum -y update を実行しましたら
今まで溜まっていた更新を無事に終了できました。
本当にありがとうございました。

教えてくださいました yum clean all とは
yumをリセットすると考えてよいのでしょうか??

どうぞよろしくお願いします。

 Re: YUM実行時に表示されたErrorについて ( No.4 )
日時: 2009/07/31 16:55
名前: ken@CentOS

http://www.atmarkit.co.jp/flinux/rensai/linuxtips/611usefllyum.html
こちらで説明されているので見てみてください。
 Re: YUM実行時に表示されたErrorについて ( No.5 )
日時: 2009/07/31 20:09
名前: 勝美

ken@CentOSさん

お礼が遅れてしまいまして失礼いたしました。

> ダウンロードしたパッケージと古いヘッダを削除する。
たしかに理解できました。

掲載してくださいましたURLはさっそくブックマークしましたので
今後も参照させていただきます。

このたびは本当にありがとうございました。
これにて閉じさせていただきます。

■ その他

ページ先頭へ


Copyright(©)2004-2018 First home server construction. All Right Reserved.