はじめての自宅サーバ構築 - Fedora/CentOS -
Last Update 2018/01/16
[ 更新履歴 ] [ サイト マップ ] [ 質問掲示板 ] [ 雑談掲示板 ] [ リンク ]
トップ >> 当サイト情報 >> スレッド

このページは表示専用です。新規投稿・レスや最新情報はこちらです。

このスレッドはクローズされています。記事の閲覧のみとなります。

 HotSaNICとlm-sensorsのバージョンについて
日時: 2009/04/25 00:40
名前: みかん   <dbs@vivamikan.no-ip.org>

1.不明点・障害内容:yumでnet-snmpをインストールすると、同梱される
           lm_sensorsのバージョンが古いことへの対策
2.ログの有無   :無し
  (有:その内容) :
3.Distribution  :CentOS x86_64
      Version :5.3
4.Service Name  :lm_sensors
      Version : 2.10.7-4.el5
5.ネットワーク構成:

HotSaNICにてlm_sensrosの情報を表示しようと思っているのですが
yumにてnet-snmpをインストールした場合、一緒にインストールされる
lm_sensorsのバージョンが余りにも古いため、チップセットに対応していません。
(最新バージョンは3.1.0)

最新バージョンをダウンロードしてmakeしても上書きにはならないのですが
何か、解決方法はありますでしょうか?

■ コンテンツ関連情報

 Re: HotSaNICとlm-sensorsのバージョンについて ( No.1 )
日時: 2009/04/25 16:55
名前: ken@CentOS

net-snmpがインストールされていれば削除する
>net-snmpがインストールされているとlibsensors3が依存関係でインストールできない
>作成したRPMパッケージも同様


[root@server ~]# yum -y remove lm_sensors
>>↑これで一度に削除できる

checkinstallをインストールしてlm_sensorsのRPMパッケージを作成

[root@server ~]# rpm -q checkinstall
パッケージ checkinstall はインストールされていません

>DAGからインストールできるようにしておく

[root@server ~]# yum --enablerepo=dag -y install checkinstall

>lm_sensorsのRPMパッケージを作成する

[root@server ~]# wget wget http://dl.lm-sensors.org/lm-sensors/releases/lm_sensors-3.1.0.tar.bz2

[root@server ~]# tar jxvf lm_sensors-3.1.0.tar.bz2

[root@server ~]# cd lm_sensors-3.1.0

[root@server lm_sensors-3.1.0]# make

[root@server lm_sensors-3.1.0]# checkinstall

checkinstall 1.6.0, Copyright 2002 Felipe Eduardo Sanchez Diaz Duran
      This software is released under the GNU GPL.


The package documentation directory ./doc-pak does not exist.
Should I create a default set of package docs? [y]: y ← y エンター

Preparing package documentation...OK

Please choose the packaging method you want to use.
Slackware [S], RPM [R] or Debian [D]? R        ← R エンター


Please write a description for the package.
End your description with an empty line or EOF.    ←エンター
>>

**************************************
**** RPM package creation selected ***
**************************************

This package will be built according to these values:

1 - Summary: [ Package created with checkinstall 1.6.0 ]
2 - Name:  [ lm_sensors ]
3 - Version: [ 3.1.0 ]
4 - Release: [ 1 ]
5 - License: [ GPL ]
6 - Group:  [ Applications/System ]
7 - Architecture: [ i386 ]
8 - Source location: [ lm_sensors-3.1.0 ]
9 - Alternate source location: [ ]
10 - Requires: [ ]
11 - Provides: [ lm_sensors ]

Enter a number to change any of them or press ENTER to continue:   ←エンター

Installing with make install...


/_/_/_/_/_/_/_/_/_/_/_/_/_/_/ 省略 /_/_/_/_/_/_/_/_/_/_/_/_/_/_/


**********************************************************************

Done. The new package has been saved to

/usr/src/redhat/RPMS/i386/lm_sensors-3.1.0-1.i386.rpm
You can install it in your system anytime using:

   rpm -i lm_sensors-3.1.0-1.i386.rpm

**********************************************************************


[root@server lm_sensors-3.1.0]# cd

>i386である事を注意

[root@server ~]# wget ftp://ftp.pbone.net/mirror/atrpms.net/el5-i386/atrpms/testing/libsensors3-2.10.6-55.el5.i386.rpm

[root@server ~]# rpm -Uvh libsensors3-2.10.6-55.el5.i386.rpm

[root@server ~]# rpm -Uvh /usr/src/redhat/RPMS/i386/lm_sensors-3.1.0-1.i386.rpm

[root@server ~]# rm -f libsensors3-2.10.6-55.el5.i386.rpm

[root@server ~]# rm -f /usr/src/redhat/RPMS/i386/lm_sensors-3.1.0-1.i386.rpm

[root@server ~]# rm -f lm_sensors-3.1.0.tar.bz2

[root@server ~]# yum -y install net-snmp
 Re: HotSaNICとlm-sensorsのバージョンについて ( No.2 )
日時: 2009/04/26 03:14
名前: みかん   <dbs@vivamikan.no-ip.org>

>>ken@CentOS 様

ご回答頂きありがとうございます。

>>DAGからインストールできるようにしておく
>
>[root@server ~]# yum --enablerepo=dag -y install checkinstall


↑についてなのですが、http://cmslab.jp/uncategorized/1433.htmlを参考に
dag(rpmforge)からインストールできるようにしたのですが、checkinstallは
「No packegeだよ」と言われてしまいます。

yum --enablerepo=dag list
or
yum --enablerepo=rpmforge list

でdag(rpmforge)のファイルは確認できるので、dagの認識は出来ていると思うのですが…

何か私の勘違いがあるのでしょうか?
 Re: HotSaNICとlm-sensorsのバージョンについて ( No.3 )
日時: 2009/04/26 09:58
名前: ken@CentOS

すみません。以下にel5.rf.x86_64.rpmが無いですね。
http://dag.wieers.com/rpm/packages/checkinstall/

el4でも問題ないので
wget http://dag.wieers.com/rpm/packages/checkinstall/checkinstall-1.6.0-3.el4.rf.x86_64.rpm

rpm -Uvh checkinstall-1.6.0-3.el4.rf.x86_64.rpm

手動でやってください
 Re: HotSaNICとlm-sensorsのバージョンについて ( No.4 )
日時: 2009/04/26 12:52
名前: みかん   <dbs@vivamikan.no-ip.org>

>>ken@CentOS 様

重ね重ねありがとうございます。

checkinstallをすると

**********************************************************************

Done. The new package has been saved to

/usr/src/redhat/RPMS/i386/lm_sensors-3.1.0-1.i386.rpm
You can install it in your system anytime using:

   rpm -i lm_sensors-3.1.0-1.x86_64.rpm

**********************************************************************

と出たので、libsensorsを

wget ftp://ftp.pbone.net/mirror/atrpms.net/el5-i386/atrpms/testing/libsensors3-2.10.6-55.el5.x86_64.rpm

に変更して、インストールしました。

[root@xxx ~]# rpm -q lm_sensors
lm_sensors-3.1.0-1

と、無事インストール出来ました。

とはいえ、A7DA-Sだと温度が表示されなかったのが、寂しい所ですが…
センサーは対応してるはずなのになぁ。

しかし、当初の目標は、無事達成されました。
ありがとうございました。

■ その他

ページ先頭へ


Copyright(©)2004-2018 First home server construction. All Right Reserved.