はじめての自宅サーバ構築 - Fedora/CentOS -
Last Update 2018/01/16
[ 更新履歴 ] [ サイト マップ ] [ 質問掲示板 ] [ 雑談掲示板 ] [ リンク ]
トップ >> 当サイト情報 >> スレッド

このページは表示専用です。新規投稿・レスや最新情報はこちらです。

このスレッドはクローズされています。記事の閲覧のみとなります。

 PHPのアップデート 実験してたらスレ閉じられました
日時: 2008/09/30 21:00
名前: ken@CentOS

phpを5.2にする手順・・・

# rpm --import http://www.jasonlitka.com/media/RPM-GPG-KEY-jlitka

# vi /etc/yum.repos.d/utterramblings.repo
[utterramblings]
name=Jason's Utter Ramblings Repo
baseurl=http://www.jasonlitka.com/media/EL$releasever/$basearch/
enabled=1
gpgcheck=1
gpgkey=http://www.jasonlitka.com/media/RPM-GPG-KEY-jlitka

# yum update php

enabled=1を0にする


これだけアッデートされたが・・・  ん?
php-5.2.6-jason.1.
php-common-5.2.6-j
php-cli-5.2.6-jaso
php-mysql-5.2.6-ja
php-pdo-5.2.6-jaso
php-mbstring-5.2.6


phpmyadminをsvn checkoutコマンドで再インスコしwebブラウザで確認すると

mcrypt 拡張をロードできません。PHP の設定を確認してください

と・・・

# rpm -q php-mcrypt
php-mcrypt-5.1.6-15.el5.centos.1

php-mcryptはアップデートされないので別で入れ直さないと駄目です。

どっちもどっちで面倒です。


以前のスレ主さん、一応レスくださいね。

■ コンテンツ関連情報

 Re: PHPのアップデート 実験してたらスレ閉じられました ( No.1 )
日時: 2008/09/30 22:02
名前: Miyabi

ken@CentOS 様

大変に失礼いたしました(汗
動作するようになったので、あせってしまいました…

私も、クライアントから見てみましたら、やはり
「mcrypt 拡張をロードできません。PHP の設定を確認してください」
と出ていましたので、再実験を試みようと思っていました。

で、今、もう一台、余っているPCにCentOS5をインストールして
実験してみようと思っていました。
が、ハードディスクも怪しかったので、DESTROYを使って
消去し始めました。


今度は、ken@CentOS様の実験と同じく、
PHPをバージョンアップに挑戦してみます。

よろしくお願いします。
 Re: PHPのアップデート 実験してたらスレ閉じられました ( No.2 )
日時: 2008/09/30 22:15
名前: ken@CentOS

>今度は、ken@CentOS様の実験と同じく、
>PHPをバージョンアップに挑戦してみます。


止めた方が良いです。

今インストールしているphpMyAdminは2.11.9.2ですよね?

# yum -y install php-mcrypt

これで mcrypt 拡張をロードできません。PHP の設定を確認してください は、出ないはずです。

phpを5.2にしてもphp-mcryptが5.1ではダメで最新のphpmyadminを入れた場合php-mcryptを
バージョンアップしないとエラーが出ます。

php-mcrypt5.2のrpmパッケージを探しましたがCentOSでは、まだ無いようです。
(あったら教えて下さい)


 Re: PHPのアップデート 実験してたらスレ閉じられました ( No.3 )
日時: 2008/10/01 06:26
名前: 中学生管理者

今更という感じで後知恵で申し訳ないのですが release notes に

Requirements for 3.0.0:
PHP 5.2+, MySQL 5.0+; refer to Documentation.html for required PHP extensions

とありますから正式にyumで5.2以上のPHPが出るまで最新版は待った方がいいと思います。
ken@CentOS様のご指摘のように管理も後々面倒になるやとも思われます。
(実験をしたいのなら、それはそれで構いませんが・・・)
 Re: PHPのアップデート 実験してたらスレ閉じられました ( No.4 )
日時: 2008/10/09 23:13
名前: ken@CentOS

中学生管理者さん、そんなのあったんですね(汗

yumでphp関連の全てがアップデートできないので、phpもphpmyadminも全て元に戻しました。


 Re: PHPのアップデート 実験してたらスレ閉じられました ( No.5 )
日時: 2008/10/01 21:00
名前: ken@CentOS

レスする度に【閉じてない】と出るので閉じておきます。

まぁphpMyAdmin3.0のインスコはyumでインスコできるPHPが全て5.2になるまで待つ

これが結論ですかね。

■ その他

ページ先頭へ


Copyright(©)2004-2018 First home server construction. All Right Reserved.