はじめての自宅サーバ構築 - Fedora/CentOS -
Last Update 2018/01/16
[ 更新履歴 ] [ サイト マップ ] [ 質問掲示板 ] [ 雑談掲示板 ] [ リンク ]
トップ >> 当サイト情報 >> スレッド

このページは表示専用です。新規投稿・レスや最新情報はこちらです。

このスレッドはクローズされています。記事の閲覧のみとなります。

 RedHat8.0でnetworkが無効?になる
日時: 2005/04/23 03:17
名前: EmiYuta   <y.n-gto@orion.ocn.ne.jp>

皆様、おせわになります。

別スレッドでRedHat8.0のサーバ立ち上げに皆様から
甚大なご指導を頂き、やっとの思いで立ち上げることがかなった
EmiYutaです。

今回、別スレッドでおかしな現象に直面しましたので
もしご存知な方がいらっしゃったら教えていただけるかなあと
思いましてご質問させて頂きました。

RedHat8.0でサーバ構築を完了し
やっと本日から常時稼動させHP公開(TestPageしかないですが)をしました。
しかし、いつの間にかネットワークから遮断されてしまうのです。
ローカルLAN内の別のマシンからサーバのIPアドレスに対して
PINGを打っても帰ってきません。

"おかしい"と思ってサーバ上のコンソールを見ると
eepro100.c:v1.09j-t 9/29/99 Donald Becker http://www.scyld.com/network/eepro100.html
などと表示されているんです。
そこでさらに
/var/log/messages
の中を参照すると下記のようになっていました。
Apr 22 03:29:30 gto8130 network: Shutting down interface eth0: succeeded
Apr 22 03:29:31 gto8130 network: Shutting down loopback interface: succeeded
Apr 22 03:29:31 gto8130 /etc/hotplug/net.agent: NET unregister event not supported
Apr 22 03:29:32 gto8130 apmd[557]: System Standby
Apr 22 03:29:33 gto8130 kernel: eepro100.c:v1.09j-t 9/29/99 Donald Becker http://www.scyld.com/network/eepro100.html
Apr 22 03:29:33 gto8130 kernel: eepro100.c: $Revision: 1.36 $ 2000/11/17 Modified by Andrey V. Savochkin <saw@saw.sw.com.sg>
and others
Apr 22 03:29:33 gto8130 kernel: PCI: Found IRQ 9 for device 00:10.0
Apr 22 03:29:33 gto8130 kernel: eth0: OEM i82557/i82558 10/100 Ethernet, 00:00:0E:C3:14:61, IRQ 9.
Apr 22 03:29:33 gto8130 kernel:  Board assembly 000000-000, Physical connectors present: RJ45
Apr 22 03:29:33 gto8130 kernel:  Primary interface chip i82555 PHY #1.
Apr 22 03:29:33 gto8130 kernel:  General self-test: passed.
Apr 22 03:29:33 gto8130 kernel:  Serial sub-system self-test: passed.
Apr 22 03:29:33 gto8130 kernel:  Internal registers self-test: passed.
Apr 22 03:29:33 gto8130 kernel:  ROM checksum self-test: passed (0x04f4518b).
Apr 22 03:29:35 gto8130 netfs: Mounting other filesystems: succeeded
Apr 22 03:29:36 gto8130 netfs: Mounting other filesystems: succeeded

どうも勝手にnetworkデーモンをシャットダウンするんです。
network: Shutting down interface eth0: succeeded
これってLinuxの仕様なんですかね〜?

皆様はこんな現象に見舞われてませんか?
これってひょっとして早速ウィルスか何か何ですか?

とりあえずサーバがNetworkに繋がるためには
/etc/rc.d/init.d/network restart
/etc/rc.d/init.d/smb restart
などとして問題なく利用できるようになりますが
3時間後にはまた同じ現象になります。

■ コンテンツ関連情報

 Re: RedHat8.0でnetworkが無効?になる ( No.1 )
日時: 2005/04/23 12:37
名前: kimio

 EmiYutaさん
 あなたの質問に直接お答えできないのが残念です。私にはわかりませんし、経験したこともありません。
 しかし、RedHat8.0をお使いでしたら、すでに訪れてみえたかもしれませんが、  
http://www.aconus.com/~oyaji/ どのが、
RedHat 9.0のインストールをして使っていらっしゃるので、こちら
( http://kajuhome.com/ )の常連さんからのレスを待ちつつ、
http://www.aconus.com/~oyaji/ どののサイトで勉強なさるとよいかもしれません。
 ところで、EmiYutaさんは、私と同類項で、基礎からしっかりlinuxを学んでいこうとされるタイプのようですね。
 ところが、このサイト( http://kajuhome.com/ )は、どうも、とりあえずlinuxを使えるようにして趣味や実益に役立てながら、それと平行して、徐々に基本的なことも身につけていきましょうという感じです。例えば、Fedora Core2 のインストール直後の設定のところに、「Linux/UNIXの標準的なエディタ。使用方法等は当サイトでは説明致しませんので、他のサイトを参考にして下さい。今後、viによる設定ファイル変更がメインとなりますので、是非ともこの機会に覚えてください。」という記述があります。
 つまり、viの使用方法については自己責任というわけです。
 だから、ここは、やはり、私といっしょに、
http://www.linux.or.jp/JF/ のサイトの記述を一字一句かみしめながら読んでいきませんか。
 
 
 Re: RedHat8.0でnetworkが無効?になる ( No.2 )
日時: 2005/04/23 09:34
名前: EmiYuta   <y.n-gto@orion.ocn.ne.jp>

kimio様

ご返信、ありがとうございます。
ご紹介頂きました一字一句のHPはkimio様に紹介して頂いてから
私も興味深々で見ています。

今日にはFedora関連の書籍をあさりに行こうと思っています。

多分来週にはFedoraのインストールを開始している?
と思いますが、今回のRedHat8.0の原因だけは
掴んでおきたいと思っています。

これからもココで色々教わっていきたいと思っています。
 Re: RedHat8.0でnetworkが無効?になる ( No.3 )
日時: 2005/04/23 11:10
名前: stratix

EmiYutaさん

質問の仕方がうまくなってきましたね。
問題がおきたときのログをさらすというのは、大変有用な情報になります。
またその際、ログを自分で勝手に要約しないことが大切ですね。
今回の場合はハードウェアに関わる部分もあるかもしれないので、
ハードウェア構成なども併せて記載しておくと、なおいいと思います。

で、そのログですが
>Apr 22 03:29:32 gto8130 apmd[557]: System Standby
この辺りを見るとAPM (Advanced Power Management)が関係しているのかもしれません。
apmdが動作しているようでしたらいったん止めて、しばらく様子を見てみたらどうでしょう?
 Re: RedHat8.0でnetworkが無効?になる ( No.4 )
日時: 2005/04/23 17:44
名前: 管理者

EmiYuta様。

stratix様が指摘した通りです。
apmdサービスがスタンバイシグナルを発行し、ネットワークが停止した模様ですね。

ただ、私自身apmdは無効にしているので動作はわかりませんが、コンソール上で何か作業を再開した場合にネットーワークが再起動しない物なんですかね?
 Re: RedHat8.0でnetworkが無効?になる ( No.5 )
日時: 2005/04/24 03:07
名前: EmiYuta   <y.n-gto@orion.ocn.ne.jp>

皆様

ご教示ありがとうございます。
ハードウェアとしましては、下記のようになります。
機種:FMV-633NU/X
CPU:Celeron333MHz
メモリ:64MB
HDD:10GB
という構成です。

皆様にご指摘いただいた通りapmが動作していました。
そこでapmデーモンを停止したところ
本現象が起きなくなりました。
ありがとうございました。

■ その他

ページ先頭へ


Copyright(©)2004-2018 First home server construction. All Right Reserved.