はじめての自宅サーバ構築 - Fedora/CentOS -
Last Update 2018/05/30
[ 更新履歴 ] [ サイト マップ ] [ 質問掲示板 ] [ 雑談掲示板 ] [ リンク ]
トップ >> 当サイト情報 >> スレッド

このページは表示専用です。新規投稿・レスや最新情報はこちらです。

このスレッドはクローズされています。記事の閲覧のみとなります。

 アップデート出来なくなりました。
日時: 2007/05/06 20:38
名前: にゃんた

fc6でサーバー運用していますが、ここ1ヶ月程アップデートが出来なくなりました。

次のようなメッセージが表示されます。
『ソフトウェアの更新中にエラー
 選択されたソフトウェアの更新中にエラーが発生しました』
『Details』には下記のように表示されています。

[('file /usr/lib/httpd/modules/mod_info.so from install of httpd-2.2.4-2.fc6 conflicts with file from package httpd-2.2.4-1.fc6', (7, '/usr/lib/httpd/modules/mod_info.so', 0L)), ('file /usr/lib/httpd/modules/mod_proxy_balancer.so from install of httpd-2.2.4-2.fc6 conflicts with file from package httpd-2.2.4-1.fc6', (7, '/usr/lib/httpd/modules/mod_proxy_balancer.so', 0L)), ('file /usr/lib/httpd/modules/mod_proxy_connect.so from install of httpd-2.2.4-2.fc6 conflicts with file from package httpd-2.2.4-1.fc6', (7, '/usr/lib/httpd/modules/mod_proxy_connect.so', 0L)), ('file /usr/lib/httpd/modules/mod_proxy_ftp.so from install of httpd-2.2.4-2.fc6 conflicts with file from package httpd-2.2.4-1.fc6', (7, '/usr/lib/httpd/modules/mod_proxy_ftp.so', 0L)), ('file /usr/lib/httpd/modules/mod_rewrite.so from install of httpd-2.2.4-2.fc6 conflicts with file from package httpd-2.2.4-1.fc6', (7, '/usr/lib/httpd/modules/mod_rewrite.so', 0L)), ('file /usr/lib/httpd/modules/mod_status.so from install of httpd-2.2.4-2.fc6 conflicts with file from package httpd-2.2.4-1.fc6', (7, '/usr/lib/httpd/modules/mod_status.so', 0L)), ('file /usr/sbin/httpd from install of httpd-2.2.4-2.fc6 conflicts with file from package httpd-2.2.4-1.fc6', (7, '/usr/sbin/httpd', 0L)), ('file /usr/sbin/httpd.worker from install of httpd-2.2.4-2.fc6 conflicts with file from package httpd-2.2.4-1.fc6', (7, '/usr/sbin/httpd.worker', 0L))]

何のことか理解できません。
アップデートの方法を教えてください。

■ コンテンツ関連情報

 Re: アップデート出来なくなりました。 ( No.1 )
日時: 2007/05/07 17:46
名前: 管理者

コンフリクトが起きているようです。

httpd関連の設定ファイルをバックアップして、「httpd-2.2.4-1.fc6」「httpd-2.2.4-2.fc6'」をアンインストールした後に
「httpd」をインストールしてみて下さい。
 Re: アップデート出来なくなりました。 ( No.2 )
日時: 2007/05/26 17:37
名前: にゃんた

管理者様ご回答ありがとうございます。

ご指示通り
「httpd-2.2.4-1.fc6」をアンインストールし、次に「httpd-2.2.4-2.fc6」をアンインストールしようとしたところ
「httpd」のアップデートの可否を聞いてきましたので「yes」にしたところ「httpd」がアップデート出来ました。
その後「Movable Type 3.3」による「ブログ」に書き込みをしましたところ、下記エラーメッセージが表示され書き込みが出来ません。

  「/var/www/html/index.html.new」への書き込みに失敗しました:
   ローカル・ファイル/var/www/html/index.html.newが開けません:
   Permission    denied」

どこを手直しすればよろしいのでしょうか?お教えください。
 Re: アップデート出来なくなりました。 ( No.3 )
日時: 2007/05/26 18:09
名前: 管理者

「Permission denied」と出ているのでアクセス権がないためです。

# chown -R apache:apache /var/www/html/

上記コマンドを実行してapacheプロセスにアクセス権を与えてから再度確認してください。
 Re: アップデート出来なくなりました。 ( No.4 )
日時: 2007/05/26 19:02
名前: にゃんた

管理者様 早速のご回答ありがとうございます。

教えていただいた通りのコマンドを実行し、無事解決しました。

ありがとうございました。

■ その他

ページ先頭へ


Copyright(©)2004-2018 First home server construction. All Right Reserved.