はじめての自宅サーバ構築 - Fedora/CentOS -
Last Update 2018/01/16
[ 更新履歴 ] [ サイト マップ ] [ 質問掲示板 ] [ 雑談掲示板 ] [ リンク ]
トップ >> 当サイト情報 >> スレッド

このページは表示専用です。新規投稿・レスや最新情報はこちらです。

このスレッドはクローズされています。記事の閲覧のみとなります。

 Webページが表示されない
日時: 2007/03/28 16:34
名前: taka

?不明点・障害内容:CentOS4.4 Serverを使用してPROXYサーバ構築をしていますがクライアントからはWebペー
          ジが表示されません。(DNSは、別のPCを立てています)
          ポート80は開放してあり、クライアントから動作テストとしてサーバのIPアドレスを入力
          した時はデフォルトのWebページは表示されるのですが例えば、"Yahoo"のHPを開くと"ペー
          ジが見つかりません HTTP 404"となります。
          もとしかして、下記の設定間違いがあるかと思い確認もしました。

           /etc/hosts、
           /etc/resolv.conf
           /etc/hosts.allow
           /etc/sysconfig/network、
           /etc/sysconfig/network-scripts/ifcfg‐eth0
           /etc/sysconfig/network-scripts/ifcfg‐eth1
           
          以前は、違うディストリビューションでApache1.3.27を使用したときは特に設定変更はせず
          サービス起動すれば動作していたのですが今回、Apache2.0.52を使用しているのですがこの
          辺りに何か有る様な気がするのですが関係あるのでしょうか。

          もし、何かご存知の方がいればご助言又はPROXYサーバ構築のサイトなどをご存知の方が
          いらっしゃいましたら宜しくお願いします。 

■ コンテンツ関連情報

 Re: Webページが表示されない ( No.1 )
日時: 2007/03/28 22:54
名前: Jin

takaさん

Jinと申します。

環境と質問の要点が不明ですが、以下の点を考慮してください。

[前提条件]
 ・Apache2.0.52でProxy機能のみ実現する。

  もし、そのApacheでWebサーバの機能を構築しインテーネットに公開しているのであれば
  セキュリティ設定上問題となりますので、至急機能停止をしましょう。

[動作環境]
 ・ブラウザにProxyの設定を正常に行っている事を確認し使用していて「サーバのIPアドレスを入力
  した時はデフォルトのWebページは表示される」とは、今回構築のApacheのデフォルトのWebページが
  表示されていることを意味している。

[対応方法]
 ・ApacheのProxy機能は、デフォルトでは機能しません。
  各種設定を行う必要がありますが、公開用Webサーバと兼用することは非常に危険です。
  Porxyの機能は、専用のソフトを使用することをお勧めします。
  有名なソフトとしては、「squid」があります。検索エンジンで「squid & 設定」で色々な情報が
  見つかりますので試してみてください。
 Re: Webページが表示されない ( No.2 )
日時: 2007/04/04 19:35
名前: taka

Jinさん

私の説明不足に、ご助言を頂きまして有難う御座います。

今回、構築をしておこないたい事は"CentOS4.4 Server"+"Delegate"を使用してPROXYサーバを立てようと
しています。
この、PROXYサーバでやりたい事は内部から送信したメールを代理で外部送信したり又、Webページ表示が
できて内部LANを外部ネットワークから隔離(遮断)をするために"Delegate"を使用して運用したいと思っ
てます。

「squid」は、Webページアクセス時のキャッシュサーバとしての機能で今回、構築するには"Delegate"が
機能を充たしているのかと考えています。

メールの送受信は、問題無くできるのですがWebページアクセスが相変わらず表示ができません。
netstat -taコマンドで、LISTEN状態を確認した所は問題は無いかと思いましたが試しに"Delegate"の「http」
をコマンド実行して再度、LISTEN状態を確認したら「webcache」というのが表示されました。

この状態で、Webページのアクセスを行ったら問題無く表示されましたがPC起動時に同じコマンドを実行
する様にしましたがエラーは出ていないのですが「webcache」はLISTEN状態に表示されませんでした。

この、「webcache」が自動で実行ができないのは何か設定ミスとかなのでしょうか。

宜しくお願いします。
 Re: Webページが表示されない ( No.3 )
日時: 2007/04/05 23:12
名前: Jin

Jinです。

> この状態で、Webページのアクセスを行ったら問題無く表示されましたがPC起動時に同じコマンドを実行
> する様にしましたがエラーは出ていないのですが「webcache」はLISTEN状態に表示されませんでした。
> この、「webcache」が自動で実行ができないのは何か設定ミスとかなのでしょうか。


 システム起動時に自動実行できないとの事ですが、どの様に起動する設定を行っているのでしょうか?
 その部分を明示していないので回答できませんが設定が悪いと思います。
 Re: Webページが表示されない ( No.4 )
日時: 2007/04/10 15:01
名前: taka

Jinさん

何時も、ご助言を頂きまして有難う御座います。

私なりに、調べた所OS側の問題では無く"Delegate"側で有ると思われる為、こちらで質問を
させて頂くのは板違いと思いますので取り合えずCloseさせて頂きます。

私の拙い説明に、色々とご助言を頂き本当に有難う御座いました。

■ その他

ページ先頭へ


Copyright(©)2004-2018 First home server construction. All Right Reserved.